USB microphone support hasn't worked for me for years
In the 1.4.0 days, a USB plugin was created with a USB Headset option.  This plugin still exists inside 1.7.0 dev builds today!  Unfortuantely, the USB Headset functionality has never worked for me.  Not once.  The USB menu detects my microphone no problem, but no games with functionality are able to detect any microphone activity.  I've been trying to get this to work since 2019 with no success.  I've tried 5 mics, over 20 PCSX2 builds ranging from 1.4.0 to 1.7.0, and practically every release of the plugin back when it was a plugin.

Aside from just not working at all, the log occasionally spits out errors like:

MMAudioDevice::Reinitialize(): Could not create IAudioClient = 88890004

As well as never-ending packet-related errors.

Everyone I talk to about this sets it up like normal and it always works for them, yet not for me for some reason.  Every single piece of non-emulator software I've tried works perfectly with all 5 test microphones.  Windows 10 reports no issues.  I've tried adjusting every setting imaginable in PCSX2 and Windows 10 to no avail.  People are calling my statements "overexaggerations" because of how badly my experience with this feature is.  I'm not exaggerating, it's never worked for me.... except for one time in 2019 where it just randomly decided to work.  After I shut PCSX2 down that one time (it was a 1.5.0 build with the plugin installed) it's never worked again to this day.  What am I doing wrong?  Is there some kind of mic compatibility list I'm unaware of?  Is this a known bug?

Sponsored links

Well there is this:

Not sure if it would help, you could dump your usb descriptors.

Users browsing this thread: 1 Guest(s)