Unable to run DBZ Budokai 3
For some reason, i can't get this game to play. I've tried multiple versions of gsdx, multiple version of PCSX2 itself, ZeroGS.

It hanged on most of these combinations when initializing the graphics plugin. Right now, i've gotten it as far as displaying a blank screen, with the console's last line being IOP Output something. It just freezes there.

Compatibility list on the site says it's Playable ( Green ) with 0.9.6. I'm curious to know as to who and more specifically HOW that person got it right.

Specs: Q8200, 8800GT, 2GB DDR2, WinXP Pro SP3

Combinations i've tried: Latest beta versions of PCSX2 and GSDX, last stable of both, speedhacks removed, different GSDX SSE versions, ZeroGS.

It's definetly not broken, because my .hack//G.U. games play fine.

Anybody know the answer to this?

Sponsored links

You're definitely doing something wrong because it works fine here (and has been working fine for quite some time)
Use the 0.9.6 release pack and post your configuration for it.
[Image: newsig.jpg]
PCSX 0.9.6 binary


GSDX 0.1.14 SSE4.1
P.E.Op.S. SPU2 1.9.0
Lilypad 0.9.9
Linuzappz Iso CDVD 0.7.0

Emu config:

EERec fully enabled
No Speedhacks
No gamefixes
No patches

Emu hangs at 'Update IOP Module', i have to manually kill the process.
Are you running an iso or the dvd? If you are running an iso make sure you do not have it mounted with any other program.
Also use SPU2-X for sound and File->Run CD/DVD
[Image: newsig.jpg]
Obviously i'm running the ISO, that's what Linuzappz is for. I ripped it so i wouldn't have to put up with the disc drive's noisyness. And no, i don't have it mounted. Out of spite i just tried the original disc, and that didn't work, either.

And i don't want to use SPU2-X. It broke the sound for all the games i have ( Kingdom Hearts, Chaos Legion, .hack ). I doubt it makes any difference to change the sound plugin because it's the graphics plugin that seems to be failing.
First,no it is not obviously the graphics plugin. You are getting a black screen,meaning a soft crash which can be caused by nearly anything really.

Have you tried updating DirectX with the webupdater? Also,paste in [code] tags the console output and post it here
Edit: Also try going in advanced and hitting 'default'
[Image: newsig.jpg]
My DX is properly up to date. I know GSDX won't run at all with the latest updates for DX, and i used the latest SVN of GSDX.

Using defaults for the recompiler didn't help.

Here's the output from the console:

PCSX2 0.9.6 - compiled on Feb 27 2009
Savestate version: 8b400004
        CPU vendor name =  GenuineIntel
        FamilyID  =  6
        x86Family =  Intel(R) Core(TM)2 Duo CPU     E8200  @ 2.66GHz
        CPU speed =  2.622 Ghz
        Cores     =  1 physical [2 logical]
        x86PType  =  Standard OEM
        x86Flags  =  bfebfbff 0008e3fd
        x86EFlags =  20100000

        Detected MMX
        Detected SSE
        Detected SSE2
        Detected SSE3
        Detected SSSE3
        Detected SSE4.1

        F1  - save state
        (Shift +) F2 - cycle states
        F3  - load state
Bios Version 2.0




Framelimiter rate updated (UpdateVSyncRate): 59.94 fps
detected blocksize = 2048
isoOpen: D:\PS2RIPS\dbzbudokai3.iso ok
offset = 0
blockofs = 24
blocksize = 2048
blocks = 917760
type = 1
MTGS > Thread Started, Opening GS Plugin...
MTGS > GSopen Finished, return code: 0x0
No accelerated IMDCT transform found
* PCSX2 *: ExecuteBios
# Initialize memory (rev:3.70, ctm:393Mhz, cpuclk:295Mhz detected)
# Total accessable memory size: 32 MB (B:2:8:0) (370:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Feb  6 2003 08:38:48
  CPUID=2e20, BoardID=0, ROMGEN=2004-0614, 32M

# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
* PCSX2 *: ExecuteBios Complete
loadElfFile: cdrom0:\SLUS_209.98;1
loadElfFile: 3605552
loadElfFile: cdrom0:\SLUS_209.98;1; CRC = 2A4B60EB

Initialize CD/DVD Drive
Update IOP Module
Really strange...everything looks fine there. I've got the PAL version so it could be a bug only in the NTSC one but I doubt that...
So you've tried using the GSdx in the 0.9.6 release pack,setting it to pixel shader 3,checking native and DX9 hardware and got the same result? Try using DX9 software mode in case it is somehow messing up badly,but looks like an emulator issue.
Does the latest PCSX2 beta behave any differently?
[Image: newsig.jpg]
Latest beta version hangs at the line: 'MTGS > Thread Started, Opening GS Plugin...'

I have the PAL version too, so this is really awkward.

Just to be sure, i guess i'll start fresh with the 0.9.6. files. Though i really hate copying back the memcards and reconfiguring my joypads..

I'm starting to think my XP install is shot. It's been acting weirdly as of late, anyway.
Hmm ok using the latest beta try this:
Select cdvdnull as cdvd plugin,set gsdx to dx9 software renderer,go to run->execute,configure your bios and exit the emulator after you're done.
Then switch back to linuzappz and dx9 hardware and try again
[Image: newsig.jpg]

Users browsing this thread: 1 Guest(s)