Unable to run iso in OSX Yosemite
Hi there,

So I've downloaded PCSX2 version 0.9.6 as I'm currently on OSX Yosemite and I think the newer version only runs on lion. Anyway I installed it, ran the bios and it was working fine. However when I try to run my iso file on it the application runs into a problem and closes. The X11 terminal comes out with:-

ZZogl: Disabling MRT depth writing
Offset 0xea0fccf0 invalid. Legit SIGSEGV. Aborting.
pcsx2.sh: line 2: 703 Segmentation fault: 11 ./pcsx2

I installed X11 and installed nvidia cg-3.1 (not sure whether I have to do this for my laptop or not but did it anyway). Does anyone know how I can solve this issue?

I'm using a macbook pro (retina 15inch, mid 2014), i7 2.2Ghz, graphics intel iris pro1536mb.

Should note that I know 'segmentation fault' usually refers to the iso being bad, but I've tried to do it now on at least 4 other iso files and it's still not launching. I had no issue creating the iso from the disks and the disks still work fine on the PS2

Sponsored links

I should also further note that I'm now having problems just trying to run the bios on it's own when it was working perfectly well beforehand (like a few minutes ago). I keep getting the message:-
Offset 0xf8a00000 invalid. Legit SIGSEGV. Aborting.
pcsx2.sh: line 2: 1502 Bus error: 10 ./pcsx2
In my experience, the OSX version of PCSX2... just doesn't work very well. Don't get me wrong, I'm very grateful to the devs for working on a Mac version at all! But I find the best/only way to run it is to create a Windows partition in Bootcamp and install the Windows version.

And let me make a very gentle, very humble plea to the devs to update PCSX2 for OSX – thanks, guys, for putting together such a great piece of software. I can only imagine how much work it must be. Smile
This sigsegv error is answered in the FAQ as:
Quote:Okay, you need to go and rip the BIOS from YOUR OWN Playstation 2

Maybe your bios is corrupted...

Everytime I saw a segmentation fault is was due to a bad iso...
What have you tried so far? Four different games were ripped by the same program (OS)?
Do you have alternative programs to create isos?
In terms of creating ISOs from my games I've used disk utility and also nero on my computer and tried both versions of them and yeah, they both don't work which is annoying. The BIOS is from my own PS2 and works fine on windows, it's just on my mac it doesn't seem to work Sad might just have windows installed on here so I can run it off that
It's highly possible this game isn't compatible with pcsx2 for mac.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
0.9.6 is a very old version. Even if such error messages are more or less direct indicators it could be that the emulator create such errors on its own. You can try to use pcsx2-ce (a wineskin port for mac).

Users browsing this thread: 1 Guest(s)