Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Unofficial linux build
Are you sure, you have 32 bits versions and symlink are not broken.
file /usr/lib/
Then depend on the result of the symlink. On mine system it give.
file /usr/lib/

You can tune the directory path with this variable : LD_LIBRARY_PATH. It work like PATH but for so library to load.

Sponsored links

Ah ok I have 64bits versions, so i'm ***** up without chroot ?
No chroot is not mandatory, albeit easier.

I do not know for Gentoo but maybe you can install 32 bits library on /usr/lib32/ for example. Or another directory and change LD_LIBRARY_PATH.
Hi gregory, I was finally able to test the force feedback implementation (I promised that long ago I know, sorry) and also Gsdx using this build.
My previous attempts failed because of this:

So in short:

Gsdx is working better than I expected, in fact I didn't really cared about it because I was interested mainly in Force-feedback, but I must say that I'm impressed by it.
I expected PCSX2 to crawl with it and look really ugly but is not quite like that.
Yes, it doesn't look that good as zzogl but is almost there (can I force somehow the antialiasing even more to get rid of the rough edges?) and is pretty fast.

About Force-feedback.
The good: Is working.
The bad: Not working so good Smile
More specifically you barely feel it most of the time, with some moments when seems to behave almost OK...not consistent in other words.
Also the vibration is a bit confusing/not precise, sometimes starts to vibrate and doesn't stop when it should, or doesn't react when it should.
But I only tested this for a short time and maybe it's the game itself fault...I don't know.

About the weak vibration, are there any values (in the source) that I can alter in order to increase the force?
Also, I read that you bought a DS3 for testing this. Is it working OK for you?
I might buy one those eventually.

As a side note only the Logitech RumblePad gamepad is working with PCSX2/FF, the other one I tried (Xbox360) is not.

But as I said, is working! Smile
Well FF is basic it is based on SSSXPAD. I need to understand how work lillypad and do somethings similar for Onepad. I just do not have time to work on it, actually I test FF less than 5 minutes.

You can easily tune the value of FF, there are hard-coded in the file plugins/onepad/joystick.cpp

1/ The default values are located at line 105 to 165 (function JoystickInfo::InitHapticEffect). I put some random in it Tongue2 Search on google for the detail of
2/ Then some values (only force) at line 189 (function JoystickInfo:LaughoHapticEffect)

Yes the DS3 is working fine but I test the FF part only 5 minutes. I think pressure sensitivity work too but I did not have a chance to test it on game that need it (MGS3).

Hum that strange, xbox360 must work. I follow the SDL example. I guess I will need to add some print in the code.

Actually GSdx is the software rendering as the MS version. I do not think you can improve the AA. Maybe try to force MLAA on GPU.

Gregory, I was mistaken about Xbox controller not working.
It does work but vibration is even weaker on it so you really have to kick something to feel it.

For the moment I'm experimenting with different values in joystick.cpp with promising results for my gamepads.
Specially increasing the force (adding a value of 20000 at line 189) makes the gamepad more alive.
I tried the max force 32767 but it was too brutal.

Anyway, the Xbox gamepad is working, so no need to modify the code, my mistake.
Hum ok. When I get free-time, I will add a force factor controlled by an option.
I'm using ubuntu 64bit 11.04 and have installed the required binaries, emulator starts and will run fine but I cannot get the spu2x plugin to work. loading it causes pcsx2 to immediately crash
ZZogl-PG: Calling GSopen2.
ZZogl-PG: Capturing ZZOgl window.
ZZogl-PG:  Got Doublebuffered Visual!
ZZogl-PG:  Create a 3.0 opengl context
ZZogl-PG:  glX-Version 1.4 with Direct Rendering
ZZogl-PG:  Using multitexturing.
ZZogl-PG:  Maximum texture size is 8192 for Tex_2d and 8192 for Tex_NV.
ZZogl-PG: Disabling MRT depth writing.
ZZogl-PG:  Use GL_RGBA32F for blockdata.
ZZogl-PG:  Fill bilinear blocks OK.!
ZZogl-PG: Initialization successful.
ZZogl-PG: Disabling MRT depth writing.
Illegal instruction

the zero-spu-dev plugin works but is choppy sound and bad quality. Any suggestions?
Hum, there is probably an ABI incompatibility between ours dependencies and mine. I'm afraid that you will need to recompile it. For the future I am trying to create an autobuilder for latest stable debian/ubuntu.
Quote:Actually GSdx is the software rendering as the MS version. I do not think you can improve the AA. Maybe try to force MLAA on GPU.
If I'm not mistaken I'll need an ATI card for that, right? Unfortunately (or fortunately for Linux people) I have Nvidia.

Anyway, I'm puzzled by the "Edge Anti-aliasing" option in GSdx SDL (Software) configuration window.
I'm saying that because it doesn't do anything, enabled or not, during the game or before, etc.
GSdx (SDL) most of the time is working much better that ZZogl and is also faster.
But is this lack of anti aliasing that ruins the experience. FXAA also is not working for SDL version unfortunately.
So what's the catch with this AA option for GSdx SDL?
Or, can I somehow increase the resolution at which GSdx SDL is working?...throw me a straw Smile

Edit: Found an answer to my last question given by rama:
Quote:Software rendering cannot, by design, upscale the graphics.
If such a thing was possible, it'd be a hack and may not work well.

Surely many answers are in that GSdx thread but is a monster thread Smile 306 pages!
I'll need many cups of coffee to read it all.

Users browsing this thread: 1 Guest(s)