Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Very high GS percentage in software mode
#1
I seem to be the only one with this problem. When using software mode, all the games I've tried run extremely choppily, like a scratched DVD. I figured an Intel 8700 would be more than enough to run games in software mode, and I've noticed that the EE percentage at the top of the window is relatively low (about 10 to 20 percent) but the GS almost constantly reaches 100 percent. I know the GS corresponds to GPU load, but software mode doesn't use the GPU, right? I checked the task manager and it seems the GPU is barely being used at all. Does anyone know what's going on?

Specs:
CPU - Core i7-8700 @3.20GHz
GPU - GeForce GTX 970
Memory - 16GB DDR4 2666MHz

Settings:
Plugin - GSdx-AVX2
Renderer - Direct3D11 (Software)
Edge anti-aliasing on
Mipmapping on
Rendering threads - 4
All speedhacks disabled
All other settings at default

Thanks in advance.
Reply

Sponsored links

#2
The GS percentage is the load on the GS CPU thread, which in turn is what talks to your GPU on a hardware renderer, or the CPU rendering threads on a software renderer. A high percentage there can mean that the GPU (in hardware) or rendering threads (in software) can't keep up, so it jams up the GS CPU thread and slows everything down. Your GPU barely being used at all is correct for software rendering, the only action it should see is the final output to the screen, your CPU will do all the heavy lifting.

Have you tried bumping rendering threads up to 6 or 8? Also have you tried both with and without MTVU enabled?
Problems? Check out the development builds for the latest updates.

Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply
#3
Since you have an Nvidia GPU you really should be using OpenGL with that system.
Reply
#4
Well, I've tried increasing rendering threads, using the OpenGL renderer, enabling speedhacks, including the MTVU hack, switching the plugin to SSE4, SSE3 and so on, and even switching to the high performance power plan. No dice.
Reply
#5
(11-18-2018, 06:29 AM)AnkokunoHoshi Wrote: I seem to be the only one with this problem. When using software mode, all the games I've tried run extremely choppily, like a scratched DVD. I figured an Intel 8700 would be more than enough to run games in software mode, and I've noticed that the EE percentage at the top of the window is relatively low (about 10 to 20 percent) but the GS almost constantly reaches 100 percent. I know the GS corresponds to GPU load, but software mode doesn't use the GPU, right? I checked the task manager and it seems the GPU is barely being used at all. Does anyone know what's going on?

Specs:
CPU - Core i7-8700 @3.20GHz
GPU - GeForce GTX 970
Memory - 16GB DDR4 2666MHz

Settings:
Plugin - GSdx-AVX2
Renderer - Direct3D11 (Software)
Edge anti-aliasing on
Mipmapping on
Rendering threads - 4
All speedhacks disabled
All other settings at default

Thanks in advance.


Nah, GS % is the GS thread, as in, CPU thread. Software rendering can be super demanding, and some games probably won't run fullspeed on anything. What games are you trying?
#StopRNG
Reply
#6
Some of the games I'm trying include Jak and Daxter, Sly 2 and God of War 2.
Reply
#7
Those are three of the most power-hungry series you can attempt to emulate. I think in this case your CPU may just simply not be able to keep up.
Problems? Check out the development builds for the latest updates.

Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply
#8
Sorry for the late post.
Out of curiosity I tried setting rendering threads to 0 and to my surprise the choppiness went away.
Jak and Daxter is still pretty slow, but Sly 2 is relatively okay.
Reply




Users browsing this thread: 1 Guest(s)