Vibrations on the wrong controller
Hello, I've recently set up a DS3 controller via SCP drivers in order to be able to play with a wireless controller and to use pressure sensitive controls in Metal Gear Solid 2 and 3.
Everything works perfectly except for the fact that when the DS3 conrtoller is supposed to vibrate, it's actually my USB connected Xbox One controller that vibrates.

I'm Using the LilyPad svn 0.11.0 (r5875) (Modified version by SCPs drivers, here are the options i'm using:

[Image: y2No6yI.png]
[Image: h6Ypmz7.png]

It doesn't show on the screen but in the bindings I've got Big / Small motors both being assigned to the same device as the rest, Dualshock 3 #1.

PCSX2 also appears to detect a second device, Dalshock 3 #2 wich doesn't responds to any input so i guess it is NOT my X1 controller being mistaken.

Quick edit: It appears that disconnecting my X1 controller for the 46541th gazillion time solved this problem, that's.... weird. Problem solved I guess.

Sponsored links

In your Scptoolkit settings, under Service settings, check Skip occupied game slots. whats going on is that the vibration input is being sent to the xbox controller first cause they seem to occupy the same gamepad slot. if that doesnt fix it then i dunno as my 360 controller broke before i set up a ps3 controller.
Did that, I don't know if it changed anything tho since my problem solved itself ^^

Users browsing this thread: 1 Guest(s)