Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Vsync slowdown with OGL
#1
I have been noticing stutter in various games and after researching the topic for a few days I came across the EnableVsyncWindowFlag.ini suggestion. After entering that, I no longer notice stuttering (horray!). But I have now noticed that I get screen tearing in almost every game that I play when connected to an external monitor. 

Enabling vsync in pcsx2 settings fixes the tearing for every game I have tested, but on certain games, (GUN, The Godfather) it causes massive slowdown when using OpenGL. If I switch to DirectX11 the games run at full speed but the stuttering is back. 

Is there a known way to fix the slowdown on OpenGL? I am happy that I got rid of the stuttering, but now I have to deal with some games having screen tear and being unplayable if I enable vsync. 

Again, it's not every game that slows down if vsync is enabled. R&C and TimeSplitters Future Perfect for example do not have any slowdown and are smooth with no tearing. They were two games that had bad stutter before I added the flag but now run perfect. 

I'm using OpenGL at 4x native, mostly default settings for everything else except when I specific game calls for a hw hack to be enabled. 

It's also worth mentioning that when playing a game affected by slowdown with vsync, even playing at native resolution causes the frame drop. 

i5 9300h @2.4
Nvidia GTX 1650
4GB vram
8GB ram
Reply

Sponsored links

#2
I have a similar issue. You'll have a game that runs fine at fullspeed (Exceeding full speed by 30+FPS) without Vsync enabled. But if you turn on Vsync you'll start getting slowdowns.
Reply




Users browsing this thread: 1 Guest(s)