Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Way of the Samurai slowdown
#1
Hello

Im trying to get Way of the Samurai to work but I seem to be getting some slowdown.

I've tried playing it on 3x and on native and yet I get the same slowdown.

My computer is pretty old but the games I have played on the emulator have for the most part ran smoothly with me being able to finish them while playing on 3x (besides Zone of the Enders).

PC Specs

CPU - AMD Athlon II X4 630 2.80 ghz Quad core
GPU - Radeon HD 4770
4GB of ram

I am using the latest build of PCSX2
Reply

Sponsored links

#2
(07-28-2013, 12:58 AM)Jogabonito Wrote: Hello

Im trying to get Way of the Samurai to work but I seem to be getting some slowdown.

I've tried playing it on 3x and on native and yet I get the same slowdown.

My computer is pretty old but the games I have played on the emulator have for the most part ran smoothly with me being able to finish them while playing on 3x (besides Zone of the Enders).

PC Specs

CPU - AMD Athlon II X4 630 2.80 ghz Quad core
GPU - Radeon HD 4770
4GB of ram

I am using the latest build of PCSX2

SVN or stable?

Also, when you get the slowdowns what are the %'s for EE/GS/VU showing in the game window?
Reply
#3
(07-28-2013, 01:14 AM)Koji Wrote: SVN or stable?

Also, when you get the slowdowns what are the %'s for EE/GS/VU showing in the game window?

SVN and the percentages range EE 70-75%, GS is 95-100%, VU 50-55%
Im using build 5706
Reply
#4
Your GPU is too weak then.
Specs: Intel Pentium P5 @ 60 Mhz, 1 Gigabyte HDD, OS: DOS
Reply
#5
Your GS load is high, try reduce d3d internal res
Im sorry i often misstype because im using cellphone...Y( '',)Y
Reply
#6
(07-28-2013, 04:55 AM)ItsGreat Wrote: Your GPU is too weak then.
Not necessarily... GS% being too high can still be a sign of CPU being too slow especially when...
Quote:Your GS load is high, try reduce d3d internal res

As he stated, 3x or native breeds the same results. Also, you have that backwards, if the GS% is super high, it's most likely NOT d3d res set too high... where as if EE and GS% were very low (anything below 70% on both) and getting slowdowns, that usually indicates that internal resolution is too high. This is because the CPU has to wait for the GPU to finish before it can do anything else, leaving the CPU idle (remember, EE, GS, and VU%'s only show CPU load on those threads, nothing more)


What IS clear is that the GS thread is being maxed out. In some cases enabling (or disabling if it is enabled) 8-bit textures can fix that. If not, another solution is to try software mode (f9), since you're on a quad core you'd want to set it to 2-3 threads... but since software mode is slower overall, it may not help on your older quad core.

As a last resort, you can try playing with skipdraw in the hacks section of the graphics plugin. This will almost certainly break some of the in-game graphics, but it might also help speed the game up (since it would literally be rendering less).
Reply
#7
Use official build with gs plugin extracted from latest svn
use direct3d9 or direct3d11 (if u'r gpu support it )
direct3d10 works great with fighting games i have tested
e.g Tekken series,Wwe series,maybe dragon ball z also
tick enable hw hacks-skipdraw=1
@ 1 not a big deal & give u speed
use highest set of instruction
e.g sse41 for hardware,avx for software
ticked-unticked allow 8 bit textures ?
Tried speedhacks different combinations ?
E.g ee to 2,vu to 2,ee to 0,vu to 2

this is all i can think of now Wink
Reply
#8
if the GPU is weak, using SW mode will show that
Reply
#9
(07-28-2013, 07:11 AM)Koji Wrote: Not necessarily... GS% being too high can still be a sign of CPU being too slow especially when...

As he stated, 3x or native breeds the same results....
i mean lower it more than it native e.g 480x320 or 320x320. I were doing it on my onboard gpu thought it give you terribly worse quality.
Im sorry i often misstype because im using cellphone...Y( '',)Y
Reply
#10
(07-28-2013, 02:56 PM)billyash Wrote: i mean lower it more than it native e.g 480x320 or 320x320. I were doing it on my onboard gpu thought it give you terribly worse quality.

If the problem is resolution being too high, than going from 3x to native would should some change... as he stated, there was no difference between the two. You also skimmed over the last part of my post explaining what to look for if resolution is set too high (you can test this yourself, set a game to 6x native that is GPU intensive and you'll see both EE and GS threads go DOWN, not up)

(07-28-2013, 10:15 AM)Preet Wrote: Use official build with gs plugin extracted from latest svn
use direct3d9 or direct3d11 (if u'r gpu support it )
direct3d10 works great with fighting games i have tested
e.g Tekken series,Wwe series,maybe dragon ball z also
tick enable hw hacks-skipdraw=1
@ 1 not a big deal & give u speed
use highest set of instruction
e.g sse41 for hardware,avx for software
ticked-unticked allow 8 bit textures ?
Tried speedhacks different combinations ?
E.g ee to 2,vu to 2,ee to 0,vu to 2

this is all i can think of now Wink

Some points on this: AVX is no different from SSE41 on hardware, there isn't any reason to recommend SSE41 over AVX to someone who has hardware support for it.

EE hacks will not help solve his problem as it's the GS thread that is causing slowdowns. VU cycle steal MAY help, but may give him false FPS readings (game will be running slower than it says).
Reply




Users browsing this thread: 1 Guest(s)