Weird Slowdown during certain games

GPU: RTX 2080 8gb
CPU: i7-9700K
RAM: 16gb DDR4
OS: Win 10

PCSX2 Build: Latest Nightly AVX2

All drivers are upgraded

Problem: So the issue is in regards to 3 certain games. God of War, Scarface: The World Is Yours, and Flatout 2.

It seems that the game boots up fine and goes into everything as normal until certain actions happens. 

for God of War, in the start of the game (the Boat) as soon as i attack and the blade hits the enemy the game slows to a crawl (7% of speed). it goes back to normal speed once the attack is finished only to slow down again once i attack, grab, or the enemies attack me.

for Scarface, during the start of the game (during Montana's last stand) it goes normal speed until he launches the rocket to the door (say hello to my little friend). after that once a gun is fired (either by enemies or me) the game slows to a crawl again (7% percent speed again).

In Flatout 2, similar to the two above, it would work as normal. even starting a race and being very careful not to hit anybody. however as soon as i bump into another car or hit a wall it slows down to a crawl again until the crashing animation is done. then it returns to normal speed.

now these are the only games i own that show on the PCSX2 Wiki as "CPU Intensive" games so i cant really test other intensive game. however games like GTA 3, Def Jam FFNY, and Twisted Metal Black work perfectly fine. im trying to run each game at 5x the resolution and lowering the resolution does help with the slowdown.

The big complicated issue i am now noticing is that once i restart my PC, and load up PCSX2 i can run those games normally Once(at 5x rez), after that i would have to restart my PC to make the games run normally again or else the problems mentioned above would start again.

Sponsored links

Have you tried setting the Power Management Mode to Prefer Maximum Performance in the NVIDIA control panel?
Windows 11 64 bit OS
Intel Core i7-10700
Geforce RTX 2060 6GB
(04-18-2022, 12:54 AM)envisaged0ne Wrote: Have you tried setting the Power Management Mode to Prefer Maximum Performance in the NVIDIA control panel?

I currently have it on Ultimate Performance

Edit: sorry, mistook it for something else.
Yes i have maximum performance for PCSX2 under Nvidia's Control Panel

Did some more testing and it seems the particles from Flat-out 2 and Scarface Causes the slowdown, while GoW there seems to be no noticeable particles but still causes slowdown.

Users browsing this thread: 1 Guest(s)