Weird controller problem in menus
I have an older laptop that I've been able to play Final X, Kingdom Hearts, and a couple of other games on without any real problems. The games don't always look great and sometimes lag but I can deal with that. Because of my computer, I've found that for whatever reason, PCSX2 works well for me. I've compared it to more recent versions of the emulator, I've tried different graphic options and speedhacks, but that version consistently gives me less lag.

So a while ago I tried playing Odin Sphere since I heard it was a game that wasn't super demanding. I eventually ran into a weird problem when I was in the shops where you buy food and sometimes in one of the game menus; when I would try scrolling, sometimes it was like my input wasn't received, or that it was taking a long time to move the cursor. The cursor would sometimes just stay there and I would have to press the buttons I have set for D-Pad Up and Down more than once to make them work. Sometimes it would skip a few menu options at a time. Sometimes it would like lag my computer just trying to process what's going. I go back to the game and it works fine, no problems, no lag in game or computer lag. I tried loading a save from the memory card rather than using a save state and the same thing happened.

I don't have this problem in any other games...until now. I'm playing Final Fantasy XII IZJS and I now have the same menu problems when before they never happened. I tried loading a memory card save, different save slots, changing key bindings, changing video settings in game so that I could be sure that speedhacks weren't affecting it, and nothing works. I even loaded a different saved game from the memory card in a newer version of the emulator and still have the same problem. I can use the menu in Final Fantasy X with no problem. Everything else in FF XII IZJS works as well as I could expect it to but for some reason the menu of all things is killing me.

The only thing that has changed since the last time I played FF XII IZJS a few weeks ago is that I had to get my motherboard and video card replaced. There was an inherent design flaw that caused the video card to stop working and thankfully the parts were replaced and installed without cost. I actually have a newer motherboard and the same type of video card as before but it has more RAM. My computer has been running just fine otherwise. Oh and I've even shut off my anti-virus while playing just in case and it still doesn't make a difference. Since I already had this problem with another game a while ago before I got those parts replaced, I don't know why getting new parts would give me the same type of problem in a different game.

Any help to understand just what the heck is going on would be greatly appreciated.

Sponsored links

pizzathehut sorry to say, but every version below 0.9.8 the devs/mods/admins won't give support, so you really need to use 0.9.8 to get help with your problem Smile
Well I've tried 0.9.8 and 0.9.9 and still get the same problem. I've turned speedhacks off, I've tried different graphics settings combinations, and nothing changes. I even tried using a different bios from someone else, and different plugins, still have the same thing happening. I've figured out emulator problems and even helped friends figure out emulator problems that they're having so I'm not a total noob with this sort of thing, but I'm really confused about this problem that I've never had before with this game.
Maybe you're just getting too low framerate during menus?
[Image: nbKSK.jpg]
Sometimes the emulator kinda lags, like I can hit Esc to try to close the emulator and it won't do anything. It only does this on the menu of all things. Anyone who has played FF XII using PCSX2 knows that if you go fight an Ash Wyrm at the earliest place in the game where you can face one, you'll get serious slowdowns there. I don't know if people with really powerful computers have this problem or not but it's a known issue. I could be there, experiencing that lag, and the game will close right away when I hit Esc.

One other weird thing is that sometimes when I'm hitting up or down in a menu and it's not responding, the cursor (which moves side to side slightly) keeps moving. The screen doesn't freeze, so it's like the idea of receiving input in that menu screen and responding right away is just too much for it to handle. It's kinda like the buffer is full and I have to wait for that simple command to be processed. But I go back into the game and I can play as normal without any problems. Why is it the menu, the graphically harmless and undemanding menu? Why did this problem from another game suddenly start affecting another game for no apparent reason?
this indicates your system is being taxed too heavily and that you are probably working around it by using some stupid gamebooster software that decreases the priority of all background processes
What are your system specs, anyway?

Have you monitored your processor when having these issues? (RAM and GPU, too)
I'm not using any gamebooster software, stupid or otherwise. It does seem like the computer is being taxed too much and yet it is only the menu where I get these delayed responses to my controls. I might get the typical slowdowns and lag in certain places but everything still responds when I tell it to. If you're familiar with FF XII there's a Clan Primer option from the menu where you can look at the bestiary and I can move around through there with no problem. In case you don't know, the normal menu is like an overlay on top of whatever you're doing in game. The Clan Primer has its own background, the game loads to a separate screen to bring it up. I quickly found out that FF XII runs a lot better when you use the game camera to view things from an overhead point of view than looking at what's going on along the horizon. There's a lot less computation involved at looking towards my feet, and I always bring up the menu while looking at my character's feet to reduce any possible menu lag, so I know that's not why I'm having this problem.

As for my specs, they're not very impressive but they've gotten the job done:
A 2 GHz Intel Core2 Duo processor.
2 gigs of RAM.
256 MB RAM Nvidia Quadro NVS 135M video card.
Windows XP Home.

I've got all my Windows updates, I've updated the video card drivers (I even got a better version of the same model of video card and motherboard than I did before so if anything the computer should be running better), I have Zone Alarm running (and even when I don't have any anti-virus running I'm still getting this exact problem) and scan with that and Malware Bytes to make sure I don't have a virus. Yes, I know I've got "lolz y u try run ps2 on dat hur hur" computer but I know the limits of my computer and I've only tried playing a few PS2 games on here that I can get to run fairly smoothly. I played Dark Cloud 2 on a friend's PS2 years ago and loved it and wanted to try it on here but I can't get it to run as well as I want to so I didn't keep playing it on here. FF XII is totally playable on my computer, I've got over 50 hours on the thing and suddenly I have this menu problem for no apparent reason.

The game runs exactly the same as it used to except the menu hates me. Since I'm not experiencing any other problems in any other computer processes or games and PCSX2 does everything else just like it used to, it seems to me like the problem is with how the computer deals with the menu overlay or how the keyboard and menu overlay communicate with one another.

I hope any of that helps, and thanks for your help.
(04-11-2012, 11:41 PM)pizzathehut Wrote: As for my specs, they're not very impressive but they've gotten the job done:
A 2 GHz Intel Core2 Duo processor.
2 gigs of RAM.
256 MB RAM Nvidia Quadro NVS 135M video card.
Windows XP Home.

sorry dude your laptop is overall too slow for a decent pcsx2 game to run.
paticually that Nvidia NVS a weak 64-bit memory bandwidth.

how old is your laptop right now?
laptop's can live 2~3 yr dish before getting a new ones.
Main PC1:i5-4670,HD7770(Active!)
Main PC2:i5-11600K,GTX1660Ti(Active!)
PCSX2 Discord server IGN:smartstrike
PCSX2 version uses:Custom compiled build 1.7.0 64-bit(to be update regularly)
smartstk's YouTube Channel
@Tallbender: not for FFX, FF12, etc. (the games this person listed)

Indeed I think the GPU is to blame here though

can you post your settings please? (pcsx2_vu.ini contents)

Users browsing this thread: 1 Guest(s)