Weird problem while running [Juiced]
So I just downloaded PCSX2 about a week ago, and I was enthralled in running Kingdom Hearts. But I decided I should expand my variety in emulation, so I downloaded Juiced (the first, best one). It started out with major lag and such, but I solved these problems by enabling certain speed hacks. Now, the ONLY ISSUE is that while attempting to race, the car will only accelerate to roughly 10mph. The car should be flying at high speeds. Its as if my 'X' button is limited? Does anyone have a solution for this? If so, any help would be appreciated!
Also, system specs:
Windows 7 (64 bit)
Intel i5 650 @3.20 GHz
12GB Dual Channel DDR3 @666MHz
Asus Motherboard
NVIDIA GeForce GT 640
Also, using a Dualshock SIXAXIS PS3 controller with MotioninJoy driver.
Thanks again,

Sponsored links

[EDIT] I fixed the problem!
I switched to LilyPad and configured it. Solved the issue right away.
Quote:so I downloaded Juiced (the first, best one)

Our forum does not tolerate any kind of warez talk / discussion / links and no support will be given as such.
Read our rules,specifically rule #1. Thread closed.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

Users browsing this thread: 1 Guest(s)