Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Weird problem with the fight with Olga in MGS2
Okay, whenever you stay stationary during this fight, she throws a grenade at you. Problem is, the grenade disappears everytime it lands, making you invulnerable to this attack. It seems like the grenade just goes right through the floor. Is there anyway to fix this? Using r5063 with all settings at default with GSdx in dx11 software mode and all speedhacks disabled.

Sponsored links

SVN builds are potentially unstable.
You could try returning to a previous revision since your issue(s) may be from recent changes.
Consider going back as far as the last stable build, which is 0.9.8 (r4600).
How do you know this issue is due to recent changes?
He doesn't, he just suggested it since SVN builds are potentially unstable. If you try it and it works with 0.9.8, then you'll know Tongue
[Image: newsig.jpg]
Ok I tested this with r4600 and it doesn't exhibit this issue but r4600 doesn't support the newer GSDX and GSDX r4600 doesn't come with an AVX edition. I tried using the latest svn with GSDX r4600 and the problem came back, so I'm definitely sure it's not a GSDX issue. Can someone look into what might have broke the newer pcsx2 to not detect when a grenade has landed on the ground? This is one of the oddest issues I've ever encountered in an emulator and it was working fine in r4600 so I'm pretty sure this should be easy to fix.
Ok so the grenade explodes in r4600 because there was a bug that prevented the grenade from landing on the ground, so it always lands on top of crates or even in mid air but this issue has been resolved in the latest svn but the grenade falls right through the ground instead of landing on the ground. This is really odd as only Olga's grenades exhibit this glitch, the grenade snake (the player) throws work just fine. Can someone move this to the bug report forum as this is obviously a collision detection problem?
Did you try setting clamping to full on both EE and VU? Did you try changing round modes? (these are the ones that can affect bugs like collision detection)
[Image: newsig.jpg]
yeah tried all that.
Hmm next step would be trying superVU instead of microVU and after that trying VU interpreters (one by one but they will be major speed killers)
[Image: newsig.jpg]
Ok I can confirm this is a microVU bug because setting VU0 to superVU fixed it. Now can you move this to the bug report forum under the microVU bug thread?

Users browsing this thread: 1 Guest(s)