Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Weird visual bug Persona 3 FES
#1
So, I'm playing Persona 3 FES and a weird visual bug keeps appearing. It's so hard to describe that I just took some screenshots and attached to here. I discovered it is related to the video plugin setting, more specifically, with the "Enable HW Hacks". With that option unchecked, the bug doesn't happen. With it checked, the bug always happens. I'm only using the MSAA of the Hacks Config. menu. Everything is unchecked and Skipdraw is at 0.

The bug is as it follows.

[attachment=44788]

Same scene, same place, same everything but with the option "Enable HW Hacks" unchecked.

[attachment=44789]

Is important to note that I also play Persona 4 and FF XII with the exact same freaking settings and never had any kind of problem. Can someone please aid me here?
Reply

Sponsored links

#2
if it's gone with Enable HW Hacks off, then play like that. P3 is quite an easy game to emulate, but it seems that if you go too high with the resolution those rainbow stripes on the floor pops up, I have exactly the same, but I learned to live with it Smile
Reply
#3
(07-01-2013, 01:19 AM)StriFe79 Wrote: if it's gone with Enable HW Hacks off, then play like that. P3 is quite an easy game to emulate, but it seems that if you go too high with the resolution those rainbow stripes on the floor pops up, I have exactly the same, but I learned to live with it Smile

I'm not too annoyed by it and I prefer live with them then turning off the MSAA. Just wanted to know if there were a work around. Oh well. Thanks a ton man!
Reply
#4
PS2 games weren't designed for MSAA and many games display bugs because of how it works. That's why MSAA is listed in the hardware hacks and not a regular option.

Instead of using MSAA you can use a higher internal resolution (which causes a SSAA/FSAA effect), or you can press pagedown on your keyboard while in game to turn on FXAA. Either method will give you anti-aliasing without the graphic bugs.
Reply
#5
How do I do that?
Reply
#6
(07-01-2013, 04:30 PM)Kallamez Wrote: How do I do that?

Press pgup on u'r keyboard to turn on Fxaa while u'r game running in pcsx2
it'll only work with nvidia Gpu
For higher resolution untick native select 2x to 6x native in video plugin setting
u'll see u'r game become more sharp & clear an anti-aliasing effect on u'r game
Note-if u experiencing slowdowns
lower u'r resolution Smile
Reply
#7
(07-01-2013, 04:30 PM)Kallamez Wrote: How do I do that?

Not sure what you mean?

SSAA (Super Sampling AA) is when you render an image larger than your resolution. Setting the resolution higher (usually 4x native res or higher) will give you a nice anti-aliased look. If your GPU can't handle it, you can instead use FXAA (or a combination of both) by pressing the pagedown button on your keyboard while in-game. In my experience FXAA isn't as dramatic of an AA effect, so you may not notice it at first. Find a still spot and turn it off and on a few times and you'll notice it however.
Reply
#8
(07-01-2013, 05:14 PM)Preet Wrote: Press pgup on u'r keyboard to turn on Fxaa while u'r game running in pcsx2
it'll only work with nvidia Gpu
For higher resolution untick native select 2x to 6x native in video plugin setting
u'll see u'r game become more sharp & clear an anti-aliasing effect on u'r game
Note-if u experiencing slowdowns
lower u'r resolution Smile


Sucks that I have a Radeon >_> . But the higher resolution worked like a charm Wink

Btw, my GPU is a HD 6870, so I guess I won't have any real problems xD. Thanks a lot mate.
Reply
#9
(07-01-2013, 08:36 PM)Kallamez Wrote: Sucks that I have a Radeon >_> . But the higher resolution worked like a charm Wink

Btw, my GPU is a HD 6870, so I guess I won't have any real problems xD. Thanks a lot mate.

Welcome Glad i helped Smile
Reply
#10
(07-01-2013, 05:14 PM)Preet Wrote: it'll only work with nvidia Gpu

WTF ? Blink it even work in Intel HD Tongue
Reply




Users browsing this thread: 1 Guest(s)