Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
What setting can fix this?
#1
Hello, I have an issue that doesn't affect gameplay (thank God) as I've fixed it by using "skipdraw" and setting it to a high value, but during cutscenes and certain levels this fix does absolutely nothing. Is there any setting within PCSX2 that could fix this for cutscenes of this game (shown in the attached pictures)? I've been trying for 2 weeks now with several combinations of settings and shaders. I have to be missing something here... Pics attached are from the game Def Jam Fight For New York. As I said, I have NO issue playing at such a high resolution on my 2080 Ti during gameplay. Matter of fact, gameplay runs at full speed, plays and looks absolutely flawless. However, even if I downscale it or put it straight to native for the cutscenes, the cutscenes do this as shown in the pictures. If u need to know my rig for further information to help me, it's below:

GPU: RTX 2080 Ti
CPU: Threadripper 2950x (16 core)
RAM: 32GB DDR4 2400Mhz
HDD: 1TB SATA SSD

I'm sure brand names don't matter for that, so I'm not putting any.  Unsure


Attached Files Thumbnail(s)
               
Reply

Sponsored links

#2
have u tried software mode?
Reply
#3
(04-20-2019, 11:09 PM)cantona Wrote: have u tried software mode?

Yes I have n it just makes the resolution native when I wanna play the cutscenes in 4K graphics or higher like 1 of my gameplay videos here: https://youtu.be/amC_VSPsZfE . Playing the cutscenes at its original native resolution plays the cutscenes fine... but again, it's playing the cutscenes at 480p then. Graphics arent being sharpened, upscaled, uprendered and polished for cutscenes like my video I shown. Only gameplay is unaffected. Maybe cuz Im playing it at 4K resolution n higher since higher resolutions use more of the GPU n it's stretching something too far in the cutscenes? Software mode uses the CPU more n doesnt give me the option to increase the native resolution like Hardware mode does. 

Playing the story mode in 4K or higher without it being blurry from it's original made resolution other than just the gameplay would be perfect. ?

That last sentence wasn't meant to be a question. I used an emoticon from my phone to reply and the site changed it to a question mark.
Reply
#4
On nvidia card it's better to use OpenGL
If you are using pcsx2 1.4.0,try the latest beta(it's miles ahead)
https://buildbot.orphis.net/pcsx2/

Custom Resolution is not recommended because it almost always cases problems that don't exist while using scaling.
The beta also have up to 12x scaling(if the game is 640x448 that will mean 7680x5376 which is way above 4k)

Also just because you have a monster gpu,that doesn't mean it's ok to use crazy scaling.
Depending on your screen size,you will probably not see any difference while using scaling above certain level(you will just make your gpu do pointless work)
Reply
#5
(04-21-2019, 12:43 AM)vsub Wrote: On nvidia card it's better to use OpenGL
If you are using pcsx2 1.4.0,try the latest beta(it's miles ahead)
https://buildbot.orphis.net/pcsx2/

Custom Resolution is not recommended because it almost always cases problems that don't exist while using scaling.
The beta also have up to 12x scaling(if the game is 640x448 that will mean 7680x5376 which is way above 4k)

Also just because you have a monster gpu,that doesn't mean it's ok to use crazy scaling.
Depending on your screen size,you will probably not see any difference while using scaling above certain level(you will just make your gpu do pointless work)

Ok, I'll try that then. Like I said in my original post, gameplay is fine. No glitches, no freezing, no slow downs, nothing. It runs at full speed with no speedhacks n is absolutely flawless with a custom resolution of 8120 by 7096. Im just tryna figure out if I can keep the same scaling n look of the game I did in that video I responded to cantona with but with the cutscenes. Lol. The cutscenes r the only thing that produce this weird artifact crap as shown in my pic attachments.

I'll reply back my progress tomorrow cuz I wont have time to test it tonight. Getting late n I got other stuff to do tomorrow. Gotta go to bed early tonight. Thanks for the help so far  Blush
Reply
#6

  1. Custom resolution can and will cause problems, avoid it whenever possible. Use the scalar that will match your monitor resolution.
  2. Half Pixel Offset can help with ghosting issues, try using it and see what happens.
  3. Your screenshots show you may have enabled some hacks but you don't show which ones. Depending on what you did, those could be screwing it up.
  4. If all else fails, there is a gamefix that will switch to SW rendering when FMVs are detected. Though, this looks like it is scripted in-engine, not video, so the results on this one may be mixed. If it fails then you can toggle SW mode on the fly with F9
Problems? Check out the development builds for the latest updates.

Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply
#7
I figured it out everyone. I took Vsub's suggestion n got the newest PCSX2 from there, switched to OpenGL, fiddled around with a lot of settings, switched to 12x native (8K) and BAM. I found out that the ghosting doesn't happen in all cutscenes. Just some of them. A lot of the cutscenes have no issues at all. The game looks terrific at 12x native on my GPU. Here is a recent video with a couple cutscenes after fixing it for the most part: https://www.youtube.com/watch?v=hp0JrRwHCX4. Now, it also seems a little slower than normal in this video and that's cuz when i recorded it, I forgot to turn 1 setting off that was causing it to slow down a tad. I just dealt with it to test out most of the beginning cutscenes at least. Game and cutscenes (with that 1 setting off I should've had off before I recorded video) now run at full speed and at 12x native on OpenGL renderer.

Some cutscenes have that ghosting still like in my original pics and post, but I'm ok with some of them having it. Nothing I can do about it. After playing thru the story farther n watching the cutscenes, it looks amazing for the most part. I guess certain cutscenes/elements just won't show correctly without ghosting unless it's played at native 480p. Weird only a few scenes have the issue but the rest r flawless :\

Thank you all so much for the help and input. I love the community and support given Smile
Reply
#8
Do you have an 8k display? Is there any merit in setting resolution to 12x Native (~4320p 8k)?
I heard about downscaling working similar to antialiasing... but does it work in this case really?
Reply
#9
Upscaling is inherently the same process as SSAA, but instead of your GPU doing interpolation and guesswork to do the AA, it has a larger number of pixels to work with and is able to just draw a more precise line in the first place. Going past your monitor's resolution and then downscaling to it does in fact improve it, but you need either the eyes of a hawk that hasn't had a meal in three days, or really lean in to your monitor to really, really notice. Especially if you're doing something like 8K -> 1080p.
Problems? Check out the development builds for the latest updates.

Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply
#10
(04-22-2019, 10:13 AM)Arethien Wrote: Do you have an 8k display? Is there any merit in setting resolution to 12x Native (~4320p 8k)?
I heard about downscaling working similar to antialiasing... but does it work in this case really?

No, I don't, but putting it on 8K makes it look more crystal clear n sharper. Compared to only the 4K setting, the 8K setting is soooo much more refined. I only play on a 4K display. Maybe has something to do with the processing of the graphics y it looks better in 8K than 4K, even tho Im only playing on a 4K display? Hard tellin  Rolleyes
Reply




Users browsing this thread: 1 Guest(s)