Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
What/who decides what game(s) are next?
#11
I didn't say anything. Multithread is a very complex topic. GSdx MT is implemented with C++11 atomic and a ring buffer from boost (it used to uses windows primitive and STL). It yields a big increase of perf in linux. And the same performance level on Windows.

There is likely a bad interaction between VS2015 / GSdx MT / Skylake CPU. Maybe there is an option to generate fast code, instead of debug/safe code. Maybe there is a bug in skylake. Maybe my code isn't good. I don't know.
Reply

Sponsored links

#12
A Skylake specific problem that happens when using hyperthreading? That sounds a lot like the Prime95 Skylake bug. Has anyone tried updating the BIOS - PC's bios, not ps2's - and check if that fixed it?
Reply
#13
I think it's the same bug. Did they already provide bios updates? I though they were at best still working on it.

Btw I think as in the Prime95 test it only manifests in AVX code. SSE4.1 could work without problems - the same if you disable hyper threading. I think Dr_hycodan validated that using his i7-6700.
Reply
#14
(04-05-2016, 04:03 PM)willkuer Wrote: Did they already provide bios updates? I though they were at best still working on it.

They did, the problem is that the vendors themselves need to release the bios update, most of them did, but even then it is board specific, not all boards got the update.


(04-05-2016, 04:03 PM)willkuer Wrote: Btw I think as in the Prime95 test it only manifests in AVX code. SSE4.1 could work without problems - the same if you disable hyper threading. I think Dr_hycodan validated that using his i7-6700.

Bugs can have very different consequences, given that both issues happen mainly - only?- on a hyperthreading enabled Skylake makes it a good chance that the root issue is the same. Hopefully they fixed the root issue and not just a workaround, but there is no way to know for sure if that helps us unless someone tries the update on pcsx2.
Reply
#15
I think some people tested a new bios without success. Are you sure that it is working fine with SSE ?
Reply
#16
Maybe I am confusing it with GIMPS. I couldn't find the reference I had in mind from dr_hycodan. For Prime95 it is only observable using AVX and not using their FMA build.

@sandman332 can you please test if this problem happens in gsdx SSE2/3.1/4 as well? I think AVX and AVX2 behave similar (as they are probably both compiled with the /avx flag).
Reply




Users browsing this thread: 1 Guest(s)