Where did I mess up ?

I'm using pcsx2 0.9.6 (binary from this site) on Ubuntu Linux 9.04, with standard packages.
My processor is an Athlon 64 3000+, which meets MMX/SSE/SSE2 requirements.
My graphic card is a Nvidia 7800 GT (pixel shader 3.x AFAIK, so no problem), and it looks properly configured since linux games like Tremulous and Nexuiz work perfectly. Driver is nVidia's, version 180, and I run compiz.
I use an European BIOS v01.60.

When I try to "run" an audio CD, everything works fine : I get in the usual PS2 config menu, can go anywhere and tweak anything, controls work fine, sound is OK, the whole thing runs at steady 45fps. So far so good.

Then I put my MGS3 (Snake Eater) DVD in drive and ask PCSX2 to run it. And here it goes :

http://dl.free.fr/ogi5ZTIXz (use link "Télécharger ce fichier")

For those who cannot or don't want to get the video, I sum it up : Sony computer entertainment screen -> Beginning of the PS2 animation -> PCSX2 or one of its modules hangs (Esc no longer works), the program has to be killed manually. CPU usage stays at 100%, RAM usage is doubled.

Since somebody got this game working, I guess that I could do the same. But I don't know how. Tried to tweak various speed & advanced settings, with no luck. It only gets to a higher framerate before it hangs, and hence hangs faster (yepeee...).

Even if I just stumbled upon a definitely broken game, tell me how I can now which part of PCSX2 crashed. This way, I may know where to file a bug report

(PS : Will now try to reboot and run it on Windows. Just in case...

EDIT : Works properly on Windows, though really slow but that's normal. Higher performance. Sounds like a linux-only bug)

Sponsored links

please, try on the last public beta for linux. I think it is 1736: http://forums.pcsx2.net/thread-9977.html
for windows you should use 1888: http://forums.pcsx2.net/thread-8317.html
Phenom II X4 940 3 Ghz / 8 gb RAM 800 / Geforce GTX 460 / win7 64
Using beta, on linux, disc isn't even detected. No matter what I do, I always go to system menu.

Sounds like a simple UNIX error however : when I look at the console output...

"GetElfName: SYSTEM.CNF not found; invalid cd image or no disc present."

And when I look on my DVD, I find a file called system.cnf.

Since linux is case-sensitive, not finding SYSTEM.CNF could be normal...
Anyway, you could not play MGS3 on linux -- overslow and overglitching. I newer use disks, only ISOs -- it's quicker and reliable. SYSTEM.CNF message is normal and should not be bug-related.
Also, please mention you're using Linux the next time. PCSX2 works best on Windows, for various well known reasons.
So unless you say otherwise, people assume you're using that version.

Users browsing this thread: 1 Guest(s)