Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Which Version Will Work With My Computer?
#1
Which version of PCSX2 will work with Win XP SP3 (32-bit)?

---

Signature

Reply

Sponsored links

#2
i'd say 1.2.1.
but we don't support it anymore
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(10-02-2020, 10:44 PM)Ariel Schnee Wrote: Win XP SP3 (32-bit)?

While there are plenty of arguments to be made that Win10 is a little snoopy, you should upgrade to Win10.
If your hardware is not powerful enough to run windows 10, you will not have a good time with PCSX2 emulation performance. Not to mention years and years of improvements and fixes that separates 1.2x with current iteration.
Reply
#4
I've solved it.

I'm using pcsx2-v1.5.0-dev-460-gc829826-windows-x86.7z from https://buildbot.orphis.net/pcsx2/index....indows-x86 . Any higher than that will not work with XP. But this one works just fine now.

I also installed the SPU2-X for Windows XP - 2.0.0 plugin from https://pcsx2.net/download/releases/arch...ugins.html . That got it to working fine too. So everything is working like it should now so yay that!^_^

---

Signature

Reply
#5
Well, ignore what everyone is telling you and do your own thing I guess. Don't expect any support going forward
Windows 10 64 bit OS
Intel Core i7-10700
Geforce RTX 2060 6GB
32 GB DDR4 RAM
Reply
#6
(10-04-2020, 02:49 AM)envisaged0ne Wrote: Well, ignore what everyone is telling you and do your own thing I guess.  Don't expect any support going forward

*Scratches head, and looks puzzled*

Why should I expect support? I'm using XP. The last thing I expect from anyone is support.

Have a nice day/night now!^_^

---

Signature

Reply
#7
I know this thread is a couple months old, but seeing you interested in XP, i'm sure you'll like what i'm about to tell:
I modified the latest version v1.6.0 to make it work again under XP. Took me a lot of time but i hope people like you find it useful.
I've opened a thread where you can check about it: https://forums.pcsx2.net/Thread-My-new-f...Windows-XP
Reply
#8
(10-14-2020, 03:30 AM)blueclouds8666 Wrote: I know this thread is a couple months old, but seeing you interested in XP, i'm sure you'll like what i'm about to tell:
I modified the latest version v1.6.0 to make it work again under XP. Took me a lot of time but i hope people like you find it useful.
I've opened a thread where you can check about it: https://forums.pcsx2.net/Thread-My-new-f...Windows-XP

Every time I try to run the BIOS it tells me "Failed to create a 2.0 context".

Happen when I try to run a game from ISO too.

I think I'll just stick with PCSX2 1_5_0 460 since it works now.

---

Signature

Reply
#9
(10-14-2020, 05:13 AM)Ariel Schnee Wrote: Every time I try to run the BIOS it tells me "Failed to create a 2.0 context".

Happen when I try to run a game from ISO too.

I think I'll just stick with PCSX2 1_5_0 460 since it works now.

ah that's because the GPU is incompatible with OpenGL 3.3, or outdated drivers.
i'm curious on which graphics card you have.
you could also try using the 1.5.0 GSDX dll and using it under 1.6.0 for better cpu performance/emulation, while using the dx9 renderer
Reply
#10
(10-14-2020, 03:50 PM)blueclouds8666 Wrote: ah that's because the GPU is incompatible with OpenGL 3.3, or outdated drivers.
i'm curious on which graphics card you have.
you could also try using the 1.5.0 GSDX dll and using it under 1.6.0 for better cpu performance/emulation, while using the dx9 renderer

I put the 1.5.0 "GSdx32-SSE2.dll" into the plugins directory of 1.6.0 .

Seems to be working now.

Will let you know otherwise.

I have a NVIDIA GeForce GTX 560 Ti video card.

Here are some screenshots of the settings.

http://www.fanficparadise.com/arielschne...ry/001.png

http://www.fanficparadise.com/arielschne...ry/002.png

---

Signature

Reply




Users browsing this thread: 1 Guest(s)