White screen upon starting
I have tried with 2 games: black and gta san andreas, from dvd drive and from mdf image. Everytime it just won't start, I have white screen. I feel this is graphics issue, I may miss a lib or something. But there are no errors. Only a warning:
Quote:UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50.00 fps
microVU1: Cached Prog = [000] [PC=0000] [List=01] (Cache=0.000%) [0.0mb]
microVU1: Cached Prog = [001] [PC=0028] [List=01] (Cache=0.000%) [0.0mb]
Gif Unit - GS packet size exceeded VU memory size!
microVU1: Cached Prog = [002] [PC=00d8] [List=01] (Cache=0.006%) [0.0mb]
microVU1: Branch VI-Delay (1) [0270][002]
microVU1: Branch VI-Delay (1) [0270][002]
microVU1: Branch VI-Delay (1) [0270][002]
microVU1: Branch VI-Delay (1) [0270][002]
microVU1: Branch VI-Delay (1) [0478][002]
microVU1: Branch VI-Delay (1) [0478][002]
microVU1: Branch VI-Delay (1) [0478][002]
microVU1: Branch VI-Delay (1) [0478][002]
microVU1: Cached Prog = [003] [PC=0308] [List=01] (Cache=0.090%) [0.1mb]

Cpu is AMD Phenom II x4 965 and gpu is Radeon HD 4850. OS is Debian Wheezy 64bit.
I have compiled it in different environment so I don't have most of packages needed to compile it.
Which libs are must have to run it properly?

Sponsored links

are you using gsdx sw mode? if so try ldd -path to gsdx plugin .so file- and show the output
best guess is you need libglew
I've installed libglew and tried with no luck. Here's the output:
I checked AMD website.


Way down the specs it says it goes up to OpenGL 3.2. GSdx, at a bare minimum, now needs OpenGL 3.3 with 4.2 being preferred. Essentially, as the packages gregory uses are updated, so are the GPU requirements. You should still be able to use ZZogl though, despite it quirks.
But how do I use ZZogl?
Config >> Plugin/BIOS selector >> Change GS plugin to ZZogl .

You should have 2 choices of ZZogl, due to being compiled one with Nvidia Toolkit and the other with GLSL. I thing both should work fine.
I didn't have nvidia-cg-dev installed, after that I can select zzogl. However, when I select it I got dialogs: "GS plugin failed to open bla bla bla drivers or hardware issue something like that"
When I select gsdx, X fails and I got following text in terminal:
The program 'pcsx2' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
(Details: serial 22 error_code 1 request_code 154 minor_code 34)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)
Segmentation fault

But if it says OpenGL 3.2 support, it doesn't have to necessarily mean that it doesn't go up, does it?
Try to make sure you are using name-brand Radeon driver.
Generally the above error occurs due to lack of OpenGL support required. I don't know if your card is considered "legacy" or not which could also affect the driver used and support received.

Users browsing this thread: 1 Guest(s)