Thread Rating:
  • 3 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windows - Compile Guide and Support
These are the steps I did.
1. Download Visual Studio Community 2015 , DirectX SDK
2. Install Visual studio (make sure to select programming language c++). ( The install will also detect if you need Redistributables , newer framework ...etc so don't worry about them)
3. Remove previous versions of 2010 Redistributables
4. Install DirectX sdk
5. Get the pcsx2 code
6. Run the pcsx2 solution file "PCSX2_suite.sln"
7. Select Release build instead of debug > Build entire solution
8. Finish

More information can be found on the wiki guide
http://wiki.pcsx2.net/index.php/PCSX2_Do...on_Windows
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply

Sponsored links

No problems with VS 2017 so far, any reason not to use it?
Had some trouble with the repo though as you now have to get the xz submodule to build everything (which you would have to do cloning from scratch as well?)
Might be worth someone who knows what they're doing putting it up on the wiki.
Reply
(11-20-2017, 06:24 AM)NZJenkins Wrote: No problems with VS 2017 so far, any reason not to use it?
The wiki is a bit outdated. VS2015 and VS2017 both are supported. Older versions no.
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply
I spent 2 hours trying to compile this. It kept on giving me errors about having an incompatible version? And the error message stated that I didn't have C++ installed, which I did. Eventually I uninstalled... SQL Server Data Tools... and now it works? Wha? It was seriously trying to treat it like a freaking SSIS for SQL Server? Go home VS, you're drunk.
Reply
(05-05-2018, 03:07 AM)watermark0n Wrote: I spent 2 hours trying to compile this. It kept on giving me errors about having an incompatible version? And the error message stated that I didn't have C++ installed, which I did. Eventually I uninstalled... SQL Server Data Tools... and now it works? Wha? It was seriously trying to treat it like a freaking SSIS for SQL Server? Go home VS, you're drunk.

For the future, unless your doing debugging/development work - you don't need to compile PCSX2 yourself.

The developer builds are readily available at http://buildbot.orphis.net/pcsx2
[Image: 36a66c559937a1f5d0cd7460362d4093.jpg?bg=2c2c2c]
Reply
(05-05-2018, 03:23 AM)CK1 Wrote: For the future, unless your doing debugging/development work - you don't need to compile PCSX2 yourself.

The developer builds are readily available at http://buildbot.orphis.net/pcsx2

Mainly I just wanted to look at the code because I'm interested in emulation, although I doubt I'll make useful contributions because C++ is not my specialty (I mostly work with SQL and C#). Thanks for pointing the builds out to me though.
Reply
A month or two ago I somewhat updated the wiki.
https://wiki.pcsx2.net/PCSX2_Documentati...on_Windows
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply
Do you have any idea off the top of your head why my compiled build is absurdly slower than the builds you linked? The gs seems to be what's holding it back... it's like at 100% load. I have a 1070 and I've tried putting the gsdx at their lowest settings, and it still crawls at like 30fps... whereas on the build you linked, or the stable build, it easily handle rendering in 8x native resolution.
Reply
Make sure you're not in a Debug configuration. These will be several magnitudes slower than a Release configuration.
Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ RGB Series, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070Ti FTW2 (8 GB)

Oh yeah Red Pandas are cool too.

Reply
(05-06-2018, 02:39 AM)pandubz Wrote: Make sure you're not in a Debug configuration. These will be several magnitudes slower than a Release configuration.

Thanks for your help. I actually did try debug, dev, and release. I fixed it by deleting and redownloading the code from github... I made some modifications to the compiler options first time around and I think borked something about that solution. Even though I reversed them and went back to the defaults... I've had this happen before on C#, compiler options that seem to stick and ruin the entire project.
Reply




Users browsing this thread: 1 Guest(s)