Won't read ISO
I'm sure this is a problem on my end, but I'm having major problems getting a game of mine to work on PCSX2. I extracted the disk data (which came out in .RAR format) and converted that to .ISO. But if I ever try to open it, it just gives me the reddish screen that says "Please insert a PlayStation or PlayStation 2 format disc".

lol which is ironically the same problem I have with my actual PS2 (though that's because of a problem with the PS2, it won't read any disks anymore). I've tried dragging and dropping the .ISO onto the PCSX2 0.9.8 (r4600) application, and I've tried mounting the .ISO to a virtual drive.

I'm not sure what I'm doing wrong or how to fix it. Any help would be greatly appreciated!

Sponsored links

Quote:I extracted the disk data (which came out in .RAR format)

And the seller at gamestop sold you the game in .Rar format ?
closed & warned for piracy
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

Users browsing this thread: 1 Guest(s)