Wrong language and no sound in Burnout 3 Takedown
Hey everyone,

I need some assistance and only posting this as forum rules say to post a new thread as the thread i was looking at was closed. However i have set PCSX2 to english and my timezone and country, however i have a European version of Burnout 3 Takedown and it loads up fine however the language is not in english and i have no sound. I have seen a thread saying to do a full boot however that hasn't worked and not sure on what to do as i can't remember if it has a language menu or not in game. Now my sound output has been set up for my gaming headset and the output is the digital optical port on my pc and i still have no sound yet if i want to listen to music as i currently am now as i type this or want to watch a movie i have no issues yet nothing when i load up Burnout 3 Takedown. If required i can post screenshots of it, any possible help is greatly appreciated as i am out of ideas.

Sponsored links

I would try doing a "full boot" of the game, some games require the BIOS to boot through before the game to get the language information, so that might help.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
I have re selected the BIOS and loaded the game yet no improvement. Just so i am doing exactly what you mean can you give a directory on what to do.
Just do as you always do - just with fullboot.
1. select iso as cdvd source and your iso to run
2. system -> boot (fullboot) to run the game.

If you did everything correct you should see the sony and ps2 logos before the game intro starts.
Yeah i did that and still not in english so i am not sure one what to do
can you please post the emulog.txt after you loaded the game ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Possibly you need to run the bios (source -> no disk) and change your bios settings.
Sure can when i get home
Yeah sounds like you need to make sure the language is set to english in the BIOS. The sound issue can likely be fixed by changing from port audio to xaudio2 in the SPU2x config
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Here is as requested the emulog.txt with the game running on my second screen.

Users browsing this thread: 1 Guest(s)