X-Men: Legends - Green Screen (v1.4.0, SSE41 GSdx)
I've been playing through X-Men: Legends with hardly any problems until today. I'm on the NYC Riots level (about 2/3 the way through the game) and when I exit the 4th street area and load into the 5th street area, I get a blank, green screen. I've tried a variety of things and googled the problem, but all that gets me is heaps of threads/videos regarding the green screen problem in God of War. I did find a thread from 2009 suggesting that a green screen could be the result of the game's CRC (whatever that is) not being added to the GSdx exception list. No idea if something like that would still be a problem 7 years later...

Things I've tried:
-Software Mode
-Switching plugin from SSE41 to SSE2
-Switching from DX11 to DX9/OpenGL
-A few HW Hacks (Pixel Offset, Skipdraw, Alpha)
-Switching BIOS from 2.20 to 2.0

My system specs:
GTX970 4GB
i5 750, 2.67ghz
WIndows 7 64-bit

Any help suggestions/ideas would be appreciated. Would hate to have to leave a game unfinished after spending 12-15 hours on it.

Sponsored links

If you grab the latest version 1.4.0, or possibly the latest Git build from the download section, the green screen shouldn't be an issue in DX11 or OpenGL, I would recommend using OpenGL however.
[Image: ref-sig-anim.gif]

I am using 1.4.0 and normally use DX11 without any issues. Tried OpenGL and the green screen still showed.
Did you put accurate blending up a little bit? you need that Smile
Also make sure the CRC level is set to the OpenGL recommended
[Image: ref-sig-anim.gif]

Just tried every setting of Accuracy Blending from 'None' all the way to 'Ultra.' Also, CRC Level was set at OpenGL recommended. Still the green screen. Also tried OpenGL Software mode as a last resort with no luck.

EDIT: Tried the above on SSE2 and SSE3 GSdx plugins, no luck. Tried OpenGL Software mode, no luck. Testing all of this with speedhacks disabled and with 2.20 BIOS.
Can you make a savestate or memory card save right before the problem area, 7zip it and send it to me so I can have a look at this?
For some reason, I wasn't able to compress thee savestate file lower than its current size of 10.8MB, which is too big for to attach on this forum. So here's a dropbox link instead: https://www.dropbox.com/s/m95xtf850v3z7l...0.p2s?dl=0
Just to rule it out as well, can you try the gsdx in the latest Git build please? Smile
[Image: ref-sig-anim.gif]

Thanks for the savestate. From my initial testing it doesn't look like a gsdx bug. I patched it to work few seconds more. Will have a better attempt at it after few hours.
Seems like it's a known bug with the game and happens in real ps2 too.

I found this and many other results on google regarding the same.


Users browsing this thread: 1 Guest(s)