Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
X-Men Legends II boots to black screen and nothing else
as title..when I boot the iso the playstation 2 appears (normal bootup, not fast obviously) but then the screen goes black and nothing else happens...EE hovers around 0-5% and GS at 0-2

I'm using PCSX 0.9.8 r4954 are there specific settings I need?

sorry but a search turned up only like 1 thing about legends 2 and it was nothing like my problem.

any other info needed just let me know.

thanks in advance

Sponsored links

i think the game is still not not sure...try the software mode and see....if not then thats probably the case
gotcha, thank you
u are welcome....did it work in software mode or it still doesn't boot up??
X-men Legends II is fully playable if only having a few glitches.

PCSX2 settings? plugin settings? Any kind of error in the log window when you get the problem?

If you have the MTVU speedhack enabled then disable it, won't work with that game.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Also, disable any kind of EE/VU Cyclerate speedhacks (if using). EE/VU Speedhacks may cause black screens. Also, use Boot Fast.

Users browsing this thread: 1 Guest(s)