Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
X-Men Origins - Wolverine [SLUS 21880]- Crash
#1
PC Specs:

CPU: Intel Core i7 @ 4.2Ghz
GPU: Nvidia GTX 1080TI 12GB

Build Description: PCSX2 1.5.0-dev2255
If other please specify: N/A

BIOS Used: USA v02.00(14/06/2004)

EE/VU Clamp modes: Normal/Normal
EE/VU Rounding: Chop/Chop

Speedhacks Used:

N/A

Gamefixes Used:

N/A

Amount of testing done (little/medium/much/completed-game): little

Comments:

First level is playable with looping voices sound. Game hangs on intro of second level (can't continue)

Bugs:

Audio looping (first level) game hangs (second level intro).

Status
Ingame
Reply

Sponsored links

#2
(01-24-2018, 04:21 AM)AVissie Wrote: PC Specs:

CPU: Intel Core i7 @ 4.2Ghz
GPU: Nvidia GTX 1080TI 12GB

Build Description: PCSX2 1.5.0-dev2255
If other please specify: N/A

BIOS Used: USA v02.00(14/06/2004)

EE/VU Clamp modes: Normal/Normal
EE/VU Rounding: Chop/Chop

Speedhacks Used:

N/A

Gamefixes Used:

N/A

Amount of testing done (little/medium/much/completed-game): little

Comments:

First level is playable with looping voices sound. Game hangs on intro of second level (can't continue)

Bugs:

Audio looping (first level) game hangs (second level intro).

Status
Ingame

did you get the same problem with 1.4.0 ?
can you please post the emulog.txt ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(01-24-2018, 07:24 AM)jesalvein Wrote: did you get the same problem with 1.4.0 ?
can you please post the emulog.txt 
Looks like you deleted the main post of compatibility report?
Reply
#4
nope, it's still there
But since I didn't move the split thread in general discussion, I guess the ng_bot got confused between the new thread and the old one.

I moved the split thread, let's see if the link comes back in the compatibility list
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
I am afraid this report is wrong. I played the game today, cleared mission 1, played a bit of mission 2 and faced no crashes.
Reply
#6
That was my guess, hence why I left the compatibility report alone Tongue
Reply
#7
(01-24-2018, 07:24 AM)jesalvein Wrote: did you get the same problem with 1.4.0 ?
can you please post the emulog.txt ?

Did not try it on 1.4.0

I have attached the emulog.txt


Attached Files
.txt   emuLog.txt (Size: 13,66 KB / Downloads: 47)
Reply
#8
(01-29-2018, 12:02 AM)AVissie Wrote: Did not try it on 1.4.0

I have attached the emulog.txt

Are you using any EE Cyclerate hacks or speedhacks?
Reply
#9
is it okay on 2251?

Edit: I just tried the SPU2-X from 1.4.0 and it's exactly the same, both have looping sound issues, but it seems to be random to how bad you get them.

Edit: Developer note

If I modify the LoopStartA writes in spu2sys.cpp line 1069 and 1076 adding

Code:
if (thisvoice.ADSR.Value == 0) //Only way I can tell if a voice is stopped currently
                thisvoice.NextA = thisvoice.LoopStartA | 1;

Then this fixes all the looping problems with the voices and music. I need the check to see if the voice is stopped as I tried The Urbz Sims in the City and without that it messed the music up totally.

It may still break other stuff though, that was just a quick fix, but might give some insight in to why the looping isn't working properly.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#10
(01-29-2018, 12:02 AM)AVissie Wrote: Did not try it on 1.4.0

I have attached the emulog.txt

Your emulog suggests you have enabled fpu compare hack. That can be the reason for crash. Please disable it.
Reply




Users browsing this thread: 1 Guest(s)