XBOX 360 Controller - XInput not working anymore
Thank you for the excellent support so far.

Not to long ago i was playing on the now upgraded 0.9.9 PCSX2 until it suddenly crashed one time.
Of course i immediately checked afterwards wether the plugins were still functional but unfortunately i noticed that in the LilyPad 0.11.0 plugin one device vanished from the list and did not reappear.
The device in question was called " XInputPad-whatever".

Ever since i m no longer able to activate forcefeedback as it is greyed out and i noticed that i can no longer press RT and LT at the same time anymore, which is really anoying as in some games it is necessary.

My 360 Controller seems to work just fine though as all functions are working in retail games as Skyrim on PC or FORZA4 on Xbox 360.

I conclude that the plugin dont recognise my 360 controller as a 360 controller (although it is still listed as a 360 controller) and thus is not able to enact XInput. Any suggestions?

BTW im using a wired 360 controller
Oh here is a pic of it.

Attached Files Thumbnail(s)

Sponsored links

unselect the directinput checkbox under game device api's and restart pcsx2
Unfortunatly that doesn work (i tried already). If i uncheck "direct input" the 360 controller will be gone as well even after reboot.
I'd suggest deleting the Lilypad.ini and also deleting the xbox360 driver from device manager, then let windows update find the latest driver for it and reinstall it.
[Image: newsig.jpg]
indeed, logical next step bositman
A logical step indeed Smile. But it doesn work either. Only the keybinding were deleted.

I forgot to mention that im using Win7 so the 360 controller driver should be automatically up to date

And i found out that PCSX2 seems to recognise RT and LT as a third axis.
That means when both triggers are pressed, they will neutralise each other out: Z-Axis:+1000 -1000 = 0. Its like neither of the triggers were pressed at all.
It is strange as it worked fine before the crash for YEARS.

Is there a way to assign each trigger as a seperate axis?
Not really, it has updated here a couple of's just plug and play so something must be wrong with your system to get this kind of problems
[Image: newsig.jpg]
The driver must be ok though as its working up to 100% in the retail games.

BTW it says that the driver is up to date.
Quote:And i found out that PCSX2 seems to recognise RT and LT as a third axis.

did you install XBCD or Motionjoy's drivers?
No what are these?. There was no need for extra software sofar as everything was working until recently.

Users browsing this thread: 1 Guest(s)