Thread Rating:
  • 53 Vote(s) - 4.77 Average
  • 1
  • 2
  • 3
  • 4
  • 5
XInput Wrapper for DS3 and USB Dual DS2 Controller
Hey guys, if anybody was kind enough to help me, can you tell me if it is possible to create custom DS4 configurations which allow all the buttons/axis etc to be the standard Xinput actions, but the PS and touchpad button assigned to keyboard buttons?

I'm not very knowledgeable in this area, so thanks for the help Smile

Sponsored links

(12-28-2014, 08:39 AM)Firedawn Wrote: Sorry, this might be answered already, but reading 3800+ messages is a little excessive.
I was trying to make both my DS3 and DS4 work simultaneously. I already had the DS4 working with DS4Tool 1.2, I went and installed this program following instructions but I get a BSOD when I start scpserver.exe, or if I connect both controllers at the same time. I uninstalled and reinstalled, but it's the same.
This is the ScpServer.log file in case it helps clear something up.

This program works fine with DS4. First Completely remove DS4tool before installing this program, then Read the OP for instructions on using the program with DS4. I have done so and have played 4 player games with 2 DS3 and 2 DS4 Laugh Works Great
I am having a hard time installing. I get an error message that says:

It is different than your screenshot but I can't seem to figure it out. Any help is greatly appreciated as I would like to fire up Shadow of Mordor!
Is there any way to get the triggers to count as buttons and swap the dpad and left analog?

I'm more used to the GUI in BetterDS3 so this is really confusing to me.
I'm lost - i wanted to test DS4windows and some other fork of it with my ds4 so i could change the damned light on ds4 - probably turn it off and make it flash just when battery is low.

after messing with that - while having scp drivers installed - bluetooth stopped working.
i've tried removing all drivers and reinstalling it, including bluetooth, ds4, ds3, and all possible variants. Tried force install, without force install. SCP driver installs bluetooth driver.

somehow SCP monitor does not detect my bluetooth adapter <- logs

USB\VID_0B05&PID_17B5&REV_0112 <- bluetooth device id

now i just want to SCP work with my DS4 - including bluetooth.
Can someone tell me how to use the Profile Manager option? I tried to create a profile where the bumper and trigger controls are switched but I couldn't get it to work. Something went wrong and it ended up deleting all the profiles that were there by default. I have a DS3 controller btw.
I just registered because I have an odd issue that I honestly dont think can be solved. I have a new Thinkpad 10 that I just got 3 days ago and was hoping to get my ds3 up and running through bluetooth. I can get the controller recognized and working with the usb cable but not over bluetooth. The tablet has a weird onboard bluetooth chip which is the issue. Ive tried manually installing the drivers many times and from many different sources. Also tried the ds3 tool program as well as scp to try to overwrite the stock drivers, all failing.

I know I can eaily buy an approved dongle and get it up and running, but this thing only has 1 usb port and I'm constantly using it for other items. It would be really convenient to use the built in bluetooth as I wouldn't use it for anything else other than the controller. I noticed that someone had the same exact issue on page 299 and he was never answered so I'm assuming this will be a lost cause lol

The issue with this driver is that while most devices hardware IDs are USB\VID_0989084, mine is BCMBTBUS\BLUETOOTH. It also doesn't show up as a device in "devices and printers" but shows up in device manager. In device manager it is listed as: "bluetooth radio", rather than "bluetooth adapter" like most others. I also tried forcing an install with Zadig but my bluetooth adapter doesn't show in the list even when I select to show all devices. I am literally out of options as I have exhausted everything I can find.

Would a ps4 dual shock be any easier to setup do you think? Or might I end up in the same boat?

**I would be willing to paypal funds to someone if they can help me solve this issue, I know time is valuable**


After further research, it appears this is a special bluetooth chip that is shared with the wifi adapter. They are probably using this in tablets to conserve as much space as possible. Doesn't look promising for me to get my ds3 running with it unfortunately.
Hello everyone. I have an Afterglow PS3 wired USB controller plugged directly into my PC with no bluetooth dongle. I've got the SCP service running. The SCP Monitor shows "Pad 1: Disconnected". I've tried various drivers including ones mentioned in this thread but none have made any difference. I'm currently using the default windows drivers. The gamepad shows up in the control panel under Devices and Printers and all the buttons and calibration work flawlessly, so I know the gamepad is functional and Windows is seeing it. Could you give me any advice to get this working?
Hello, I am now using a different dongle than the one I had before. This one was recommended by someone else as having worked for their DS3 on their computer for the past year with no problems. The dongle ID is


This is the Trendnet TBW-107UB dongle that dink recommended.

So, the drivers installed just fine, the controller shows up as USB DS3 Device, and the dongle shows up as BTH DS3 Device. But I still can't pair the controller with the dongle. It may be because I am following this instruction incorrectly:

"Pairing a DS3 to your Bluetooth Dongle - plug in the DS3 to USB while the Service is running, the DS3 will be automatically paired if required."

Am I supposed to run ScpService? I am unable to run it*, so I ran ScpServer, because I think I read at some point that it is some kind of alternate version of ScpService or something. So I ran ScpServer, plugged the controller in, tested the rumble functions, they worked fine, then I pressed pair, and it supposedly paired the controller with the dongle. But when I unplugged the controller and pressed the PS button, still nothing happened.

I plugged the controller back in, then I opened ScpPair, and a code showed up under "Local" and another code showed up under "Remote", they were 2 different codes, what do they mean, does one represent the controller and one the dongle? Then, in ScpPair, (I may have done something really stupid), I typed in the code that was under "Local", and clicked "Pair", then both of the codes (the Local one and the Remote one) were the same.

Then, on ScpServer, I plugged in the controller, and I clicked "Pair" and it said something like "DS3 paired to Bluetooth dongle." (I'm assuming I had un-paired the controller and dongle when I typed in that code to ScpPair, and now ScpServer re-paired them). So I unplugged the controller, and pressing the PS button still does nothing. And, NOW, when I plug the controller in, on ScpServer it shows "DS3 Arrival Event", BUT the controller does not show up in the top of the window as any of the "Pad"s, and all of the rumble test buttons and the "Pair" button are all grayed out, I cannot click them. Also, now nothing shows up in ScpPair. The fields for "Local" and "Remote" are blank.

Would anyone be able to help me and let me know where I made a mistake, and how I can fix it?

The controller is working just fine wired on my SNES emulator.

Also, I tried uninstalling and reinstalling. Didn't fix it.

*When I try to run ScpService, I get the following message: "Cannot start service from the command line or a debugger. A Windows Service must first be installed (using installutil.exe) and then started with the ServerExplorer, Windows Services Administrative tool or the NET START command."
AMAZING Program I have to say I am really enjoying the ease of use of it, but I have a small problem now that my ps3 controller is paired with my bluetooth dongle, the tester doesn't detect any button press.

On the monitor I can see both my bluetooth dongle and the controller is detected but it isn't receiving any input from the controller. When Connected via Bluetooth the PS3 address on SCP Monitor has; 'Mac Adress - BTH 00000000000 None' and stays that way?

When connected via wire it shows me the state of the controller i.e charging/full etc but when connected via bluetooth it just says 'none' and the numerical value doesn't increase.

It's odd, I can use the vibration testing options from the SCP server via bluetooth but I can't send the key press from the controller... hm

Okay so apparently this means the dongle isn't compatible.. Could someone tell me if this one is compatible?

Users browsing this thread: 13 Guest(s)