Thread Rating:
  • 54 Vote(s) - 4.76 Average
  • 1
  • 2
  • 3
  • 4
  • 5
XInput Wrapper for DS3 and Play.com USB Dual DS2 Controller
#41
Thank you so much for this. Now I can finally remove the garbage known as MotionJoy from my computer. This works fantasticly.
My YouTube (Kingdom Hearts II: Final Mix FULLY TRANSLATED!): http://www.youtube.com/tyestor
MyAnimeList: http://www.myanimelist.net/profile/tyestor
Last.fm: http://www.last.fm/user/tyestor
My PCSX2 settings: http://i.imgur.com/za8rp0n.png
My PC Specs: http://i.imgur.com/5bgg9P3.png
Current PCSX2 revision: r5932
Reply

Sponsored links

#42
(09-01-2012, 04:36 PM)Scarlet.Crush Wrote: @KrossX: Added X360 support as suggested, screenshot Pad 1 DS3, Pad 2 X360

Played Onimusha 2 with this config, Rumble for Pad 1 was being sent to Pad 2.
Restarted with Pad 2 (X360) disconnected and Rumble goes correctly to Pad 1.

I checked the XInput part of the source and it looked like rumble should work correctly. =S
The way I was thinking about it was just rudimentary:

Code:
l_nPads /* Number of non X360 controllers up to 4 */

XInputFunction(index, pointer)
{
    if (index < l_nPads)
    {
        return l_Pad[dwUserIndex]->Function(index, pointer);
    }
    else
    {
        return WRAP_XInputFunction(index - l_nPads, pointer);    
    }
}
Reply
#43
(09-05-2012, 09:51 AM)Tyestor Wrote: Thank you so much for this. Now I can finally remove the garbage known as MotionJoy from my computer. This works fantasticly.

Good luck with that.
I think the only way to get rid of this ***** is a fresh installation of Windows, seriously.

I tried everything, I'm really frustrated right now.Angry
Reply
#44
hey Scarlet.Crush

sorry for hijacking your thread a bit, but some users of XBCD that are using microcon wireless controllers are having issues where the Controller does not appear connected to Port 1 (Xbox control is a 3 port hub with the controller logic hard wired to port 1, the other 2 ports are for the controller mic and that rare memory pack people could get)

This only seems to be a problem on Vista/7. on Windows XP, the controller device appears fine the internal port 1.
Any idea's?
Reply
#45
@Squall: It may be similar to the issue I was having with the Play.com Dual DS2 adapter. Do the ports appear as a collection?

eg the Play.com device appears as -
USB Human Interface Device (USB\VID_0B43&PID_0003)

Ports appear as -
HID-compliant game controller (HID\VID_0B43&PID_0003&Col01)
HID-compliant game controller (HID\VID_0B43&PID_0003&Col02)

Behaviour is the same, works no problem on XP, on Vista/7 any attached DS2 is not usable/visible with standard Windows drivers.
Reply
#46
hmm, well its slightly different to that.

when you plug in the adapted/rewired xbox control it first installs as a Generic usb hub. after which an unknown device appears with the correct vid/devid will appear in the other devices category in device manager (if no compatible driver is present). This device is connected to port 1 of the generic hub.
the control (and this goes for the 360 as well) don't actually have a HID header, so the driver (both xbcd and the common class driver) emulate it.

seems only the pelican eclipse and madcats micron wireless(2.4ghz) are doing this.... so im trying to figure out what windows is doing differently to the usb device protocol. Only thing i can think of so far is that the hub is powering down port 1 using the usb suspend state :<

such a strange issue, and its not like i can just borrow one from madcats to look at either lol.
Reply
#47
Huge thanks for this ! I think I used over 20hrs trying to find alternate solution as to install windows xp reside 7 Smile

FEI: Works also with Atomicplay branded PS2 USB converter, shown as "Dual PSX-USB Adaptor" in devices.
Reply
#48
Hi Scarlet.Crush first of all thank you for this i also hate the motionjoy drivers the last time i use them it screw most all of my drivers i have been using a x360 controller but its not the same as the ds3.

But i have a little problem hopefully you can help me out with this i install the drivers called "SCPFilterDriver" when i run "SCPUser" the 64 bits version to try the control it shows my two controls the xbox one and the ds3 pressing the buttons in the ds3 shows in the program the correct one i'm pressing so i go to a game like fifa 13 demo or dark souls when the buttons changes the location for example the start button is in R3, L1 and L2 are in the up and dow keys, O is in start any way to change to the correct way? i try putting the "XInput1_3.dll" in the game directory and that does nothing and without it is the same

Thanks
Reply
#49
saekh, can you check through your post and see if theres any way you can expand and clarify your problem further.
Reply
#50
@saekh: It sounds like the games you are trying to play are not using XInput, they are using DInput. The filter does not change the mapping of buttons for DInput, and they are different from an X360 DInput mapping.

X360 with 'A' button pressed -
   

DS3 with 'X' button pressed -
   

Most DInput games let you re-map buttons from within the game, check the configuration options.

Are you using Windows 7?
Reply




Users browsing this thread: 11 Guest(s)