Thread Rating:
  • 54 Vote(s) - 4.76 Average
  • 1
  • 2
  • 3
  • 4
  • 5
XInput Wrapper for DS3 and Play.com USB Dual DS2 Controller
I’ve started using xinuput today and it works like a charm. But my problem is that I can’t move my folder because it says that it’s open in an another file. I’d checked if it was still on by using the task feature, but I couldn’t find scpservice.exe to stop it. I do have two accounts, with the other one being admin. Do I have to go to my admin user to turn it off?
Reply

Sponsored links

When I connect via Bluetooth vibration does not work. Can I solve this problem?
Reply
I seem to have an issue not related to the SCPToolkit, but I figured maybe someone here can help. When I connect the controller to my computer, the lights come on and blink just fine, however it does not show up in Devices and Printers therefore it will not work.
Reply
Did you click "Scan for New Hardware" in Device Manager? Also, what type of controller is it?
Reply
(01-22-2018, 09:52 PM)CK1 Wrote: Did you click "Scan for New Hardware" in Device Manager? Also, what type of controller is it?

I did scan for new hardware, makes no difference. It's a PS3 controller.

Also, I restarted my computer, but it doesn't help either.

EDIT: I think it's defective, I'll need to trade it in for a new one. It won't work on Linux either.
Reply
I seem to have this regular issue that's getting worse each time. When I restart/start my PC with no controllers everything is fine, but when I have to update it (restart so my friend can join via Parsec or I can change to bluetooth) it never lets me go back to XInput 0 - both PCSX2 games and my Steam games.

I've tried wiping it all, reisntallig the drivers (and completely unninstalling the bluetooth), remove devices from the Windows Xbox Controller menu, disconnecting and reconnecting, legacy server, having those 2 last Services options checked, nothing is working. I either restart my PC and hope it hops into XInput 0 or no matter how many times I try all of the above and hammer around, only get XInput 1, 2 and 3 (with all the other 3 being empty at all times). There aren't any other devices connected and I've tried completely reinstalling SCP and same issue persists.

Has anybody else had this issue before? Am I forgetting something? I always seem to be so close, but everytime it connects, it just goes to the wrong XInput.

Thank you!
Reply
Sooo... I got the controller working. Works pretty much fine, except rumble doesn't work in anything. If I test it in SCPUser.exe, it works fine, but otherwise it doesn't.
Reply
(02-21-2018, 02:14 AM)Jake1702 Wrote: Sooo... I got the controller working. Works pretty much fine, except rumble doesn't work in anything. If I test it in SCPUser.exe, it works fine, but otherwise it doesn't.

Well no rumble = longer battery life in wireless mode so its no so bad Smile

I installed SCPtoolkit using windows10 and tried with 3 different DS3. All are working with a cable but none are pairing using a bluetooth dongle. I can see a PS3 controller in the Windows Bluetooth panel once after a fresh reboot but it keeps asking for some sort of NIP which I dont have. On my Linux distro I just press the PS button and it pairs right away with the same dongle so I'm at lost now.
One of the controller is not genuine, the other twos are so it must be something I failed to comprehend.

I enjoy being able to use a DS controller in Windows10 but there are some games I'd like to try with 3 to 4 players so a cable-less solution would be great.
Reply
Windows 10 Fall creators update broke this driver for me :/ If any of you guys have the option to upgrade to it, you should decline. My system forced me to update to it. I'm pretty upset about the situation rn. I hate the way Windows forces these things
Reply
The only issue I've had since going from Windows 8 to Windows 10 is if I reboot my machine I'm forced to start the scp service manually on task manager. It seldom happens when the pc isn't rebooted (might happen once in a while but as I said rarely) though.

And my Ds3 works fine via Bluetooth with scptoolkit
Reply




Users browsing this thread: 14 Guest(s)