XInput configured and connected but not showing up in game after BT driver issues
Hi guys.

This is my first post on this forum, I hope it's in the right place.

I was using Motioninjoy for quite a while and it was working quite fine, but too complicated and not serious at all.
When I discovered your XInput Wrapper SCP, I uninstalled directly MIJ.

I followed the installation guide from Scarlet.Crush on this forum, connecting a BT dongle (and the controller).
After installing, my native BT was overwritten and the BT dongle was not in use. So I uninstalled it again, and than my native BT was broken.
I first thought it was caused by MIJ which seems to cause a lot of troubles trying to uninstall it. But it seems that my issues were caused by interference of the native BT and the dongle.
To get to this conclusion y had already uninstalled all BT related software from my system.

Than I installed again my native BT drivers and in device manager I updated the drivers of the dongle pointing at the SCP folders to substitute the original drivers with the DS3 drivers.

So far everything is working perfectly. My native BT is fine and my DS3 controller is working in SCP DS3 Monitor and all buttons are functioning in the SCPUser, via BT and USB.

BUT when I open any game, there is no way to get the controller to show up.

I tried to reinstall everything again, and installing the XBox drivers for W7 64 in compatibility mode. I read they're included in W8 since I'm running W8 64, but I still tried it. I also copied the XInput1_3.dll into the game.exe directory, but my games are still running only on keyboard.
Maybe I deleted a bit too much, being paranoid of MIJ hidden drivers...

Before I uninstalled everything, I tried SCP via USB and it was working fine.

After so many days of fixing I got so close,
any idea how to get the last steps fixed?

Thanks for any help and for this great free, simple and functioning software.

Sponsored links

Hi everybody.

I just checked the joy.cpl in the execute field at the home button and now it shows an XBox controller connected!
I tried directly a game and IT'S WORKING!!

I have absolutely no idea why...I didn't changed absolutely ANYTHING and before I've been restarting a hundreds of times already.

Problem solved.
Kind regards.

Users browsing this thread: 1 Guest(s)