XInput on 1.2.1
So I saw that 1.2.1 was released and I jumped on it. Been playing Persona 4 for a few hours and I noticed that the cursor goes crazy when I'm in a store. Not sure why. So I started playing around with the controller plugins and it seems like it just goes crazy when I'm using an XInput wrapper. If I switch to directX it works fine. Although I lose rumble. For P4 that's not a huge loss, but it would be in other games.

I've figured out that only the store menus on this game use the left/right joystick for pageup/pagedown. So that's why it only affects there. I can run around fine and stop fine. I tried adjusting the dead zones and re-calibrating the controller to no avail. It's odd.

Anyway, maybe someone that knows more can look at it, or suggest what I'm doing wrong? For now I'm going back to the SSSPSX PAD cause it's working.

Sponsored links

There's a special lillypad version for the xinput wrapper. It's should be included in the ScpServer\bin\Win32\ folder
Also, make sure to drop the hacked XInput1_3.dll in the pcsx2 root folder
Thanks for the response. But I'm probably retarded or just looking in the wrong place. I looked in the install folder ...\program files (x86)\pcsx2 1.2.1\bin and there's not a Win32 folder. So I ran a windows search "kind:=folder ScpServer" on the C:\ drive and got nothing. I tried checking the SVN and git for that folder and found nothing.

I know there was some hacked files for 1.0.0r5818 that needed to be downloaded for XInput to work, but in 1.2.1 it was all included with the installer. As was padPokopom. Both Poko and Lilypad seem to have the same issue with XInput. Lilypad works fine in directX mode as well. Again, aside from the rumble.

I am using a 360 controller if that matters. Windows 7 x64, used the installer (top link), and my bios says "US v2.00(14/06/2004)" My 1.0.0 version doesn't have issues with XInput, (in lilypad at least. I never got Pokopom working) but it doesn't have any XInput1_3.dll files. If this has already been asked, feel free to shoot me a link. My searches of the forum and google didn't turn up anything, though I may not have used the right queries.

Also, I have to restart the audio engine frequently by going to config/Audio (SPU2)/Plugin Settings... then hitting cancel. That forces a sound engine reboot and my sound comes back. But I'm not 100% sure that isn't my crappy sound card's fault. It did it sometimes in r5818 too. Mostly just on Atelier Iris though.

Users browsing this thread: 1 Guest(s)