Xbox 360 controller not responding
Hey guys,

I have a kinda weird problem with my xbox 360 controller. It does work fine in pcsx2 (I already beat KHFM with it; was the only iso I played with it for some months), but when I try to play Resident Evil 4 or Ico, the controller doesn´t respond while the game starts and everything. Both games have some sort of language selection menue when you start them, but my controller just doesn´t work. I already tried everything i could think off, reconfigured LilyPad, reinstalled drivers, still not working.

Someone has/had the same problem?

Sponsored links

Start by posting a screenshot of your lilypad button mapping.
[Image: newsig.jpg]
Here they are:

I had a bug which made the controller unresponsive at a language selection screen... I think it was Code Veronica's. Maybe is some similar bug?

Give it a try:
If it works, then it's a plugin bug indeed. I think it was the pressure mask, but I can't remember now.
[Image: nbKSK.jpg]
Thanks a lot, that plugin seems to solve my problem! Although I can´t seem to configure my controller anywhere Wacko But I can finally start the games properly, big thanks to KrossX Smile
There's only some very basic configuration to swap analogs and that's it (for Quake on PSX mostly). It wasn't meant to have one when I made it though. =P

Can you post the catalog/serial number of the games that affect LilyPad? You know, the SLUS-##### number thingy.
[Image: nbKSK.jpg]
Sure! Since I don´t have many isos, there were only two which were affected, those were:

ICO [SCES 50760]
Resident Evil 4 [SLES 53756]

Thanks again for fixing my issue Smile
No problem, but the issue would still remain in LilyPad though. I cannot use the emulator yet, but I've checked the source and only found a little difference on the poll mask.

There are 18 response bytes, 2 for digital stuff, 4 for the analogs and 12 for the pressure things. My default mask is FF FF 03, to account for all 18; while LilyPad's is FF FF 00. The mask is requested on command 0x41, so maybe it doesn't like not having that default? I'll check it tonight if I can.

(the post is more of a reminder on where to look at, since I'll most likely forget XD )

#EDIT: No problem with LilyPad ... ¬_¬
So... neither the dpad nor the X button worked to select the language and all? Cuz it worked for me.
[Image: nbKSK.jpg]
Yea, no button has worked for me, mashed the whole pad, nothing happened; but the language menues have some little animations, so I could see that my pcsx2 hasn´t crashed or anything, it was just the controller that wouldn´t react at all.
But that plugin there works like a charm, it has the right key binding by default and seems to work with every iso I have.
Yeah, it was meant to be a plug and play thing cuz I was getting lazy with configuring the pad every now and then. Still, can you please attach your LilyPad ini here?
[Image: nbKSK.jpg]

Users browsing this thread: 1 Guest(s)