Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Xenosaga 2 & 3 flat black square floor glitch
#1
The issue occurs to varying degrees in different areas, such as Uzuki household and space port.  Some areas are unaffected, while others have up to around 50% of the floor covered in a flat black square that stays at the same relative proximity to the main character.  It does not occur in battles or FMVs.  If I am loading a save in an area that shows the glitch, the glitch will not be present until I leave and re-enter that area, or do something like return from a battle.  In certain areas, pressing F9 to switch back and forth from software mode will fix the glitch until I come out of a battle and then I press F9 over again to fix it.  I have found that when CRC is set to aggressive (very common in settings I see online for this game) that objects with height like rocks will pop in and out of view through the black square, and that is the best I have been able to do when tweaking every setting in both OpenGL and DX11.  OpenGL is the winner due to showing clouds in the main map of the Kukai Foundation and I am certain it fixes more than that.  Randomly when running in DX11 mode will cause the game to alternate frames by 1 pixel horizontally causing a constant shake and flickering of lights as if it is trying to cause me to go into a seizure, so I have given up trying to make that work for other reasons.  I have tested all hacks in HW Hacks including half-pixel offset, sprite, and round sprite options.  CRC, Accurate Date, and Blending Unit Accuracy in DX11 and OpenGL.  On a side note, I havent tested Xenosaga 3 past the first 20min of the game, but it seems the only difference is I need to set CRC to aggressive for the game to look proper in the cutscenes if not other parts of the game, but past that the flat black boxes on the floor becomes an issue the very first time you gain control of the character and go to the save and return the glitch will be present. 

Update: Tested with the stable release version 1.4 and with OpenGL had the same glitch occur when testing with same settings except changed CRC set to aggressive, half-pixel offset, align sprite and hardware depth enabled.

v1.5-2779
OpenGL
16:9
6x native
Allow 8-bit textures
Large Framebuffer
CRC: Partial
Blending Unit Accuracy: Basic (tested High and Ultra with no improvement)
HW Hacks: Merge Sprites (required to show character shadow and more)

i7-860 @3.5Ghz
2x4GB G.Skill 1866 DDR3
GTX1070 SC
Win 10 Pro x64
Reply

Sponsored links

#2
I suppose there is no fix for setting it at 6x native. However by setting a custom resolution of 2561 x 1600 to be 1 higher than my native resolution of 2560 x 1600 the problem is fixed. Unfortunately that leaves me unable to play at a higher internal resolution unless I go out and buy a 4K, 5K or 8K display.
Reply
#3
Would be helpful if you could post some memory card saves at the spots where the bug is visible, and a GSdump (https://forums.pcsx2.net/Thread-How-to-c...er-GS-dump)
[Image: newsig.jpg]
Reply




Users browsing this thread: 1 Guest(s)