Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Xenosaga Episode 1 Area Transition Issues
#1
I have been playing this game on stream and having issues with the "Encephalon" map in the EVSĀ (Environmental Simulator).

Examples are in the train station, if I take the bottom stair in the 2 stairs on the bottom then the screen has a weird camera angle and locks the character in place, you can run in place and spin in circles, but you are 100% stuck in that position. That one can be circumvented by taking the top stair of that set, now the problem is the second instance of this bug in the "Encephalon" map.

The area you go to get the S. Carrot Juice. You can go into the area fine without encountering the bug, but the bug happens on the return from that area, locking you in place, making it impossible to get the S. Carrot Juice, which unfortunately makes it impossible to complete the giant robot part of the game, making it impossible to 100% the game, because the segment address decoder for the door with that robot part is kept in the chest in the bunny's house in the "Encephalon" map, does anyone have a fix? Please, I have tried everything I can possibly think of, but I don't know any programming or hex editing shenanigans, so all I've done is tried different BIOS' and different roms.

Please can someone help?

Also. if anyone has a fix for the ladder issue that would be nice as well, since there are a few ladders that I can't dismount if I mount them from the bottom and go up to the top, I can't dismount them from the top.

Sponsored links

#2
I fixed it, with the very last thing I could think of, playing around with the Emulation Settings themselves.
I changed EE/IOP
From: EmotionEngine (Recompiler), IOP (Recompiler), Round Mode (Positive), Clamping Mode (Normal)
To: EmotionEngine (Recompiler), IOP (Recompiler), Round Mode (Chop/Zero), Clamping Mode (Normal)
and changed VUs
From: VU0 (superVU Recompiler [legacy]), VU1 (superVU Recompiler [legacy]), Round Mode (Negative), Clamping Mode (None)
To: VU0 (microVU Recompiler), VU1 (microVU Recompiler), Round Mode (Chop/Zero), Clamping Mode (Normal)

And these changes seem to have fixed both the area transitional bug, AND the ladder bug.
Keep in mind, I have NO IDEA what any of these things actually do, all I know is that changing them to this fixed these issues for me.
#3
Our forum does not tolerate any kind of warez talk / discussion / links and no support will be given as such.
Read our rules,specifically rule #1. Thread closed.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go




Users browsing this thread: 2 Guest(s)