Xenosaga Episode II GS Campaign 02 "Go Postal" letter delivery not registering
Hi, I'm finally emulating Xenosaga Episode II (US) and it is absolutely gorgeous in HD glory, everything seems to be working just fine, except for the GS Campaign 02 sidequest "Go Postal" letter delivery is not registering the letters were delivered and I can't complete it. When I deliver the letters (to the right people) and talk to them again, they keep asking for me to hand it to them, and I select to hand over the letter again. They do respond with the typical thank you response as I remember it from the PS2, but if I talk with them afterwards they ask for it again. I thought it was weird and when I return to sikes for the reward he says I haven't delivered them.

This is the 3rd time I play this game (first time emulated) and I never had troubles completing this campaign so I am sure I have some settings wrong in the emulator. The swimsuit contest posters also disappeared even though they're supposed to stay up for the remainder of the game, but I don't care because it's registered as completed. Has anyone else experienced these nuances in the side quest GS campaigns? I ran a site search and couldn't find related threads. 

Here are my specs, I AM using code cheats:

Windows 10 Pro x64
CPU: Intel i7-6700HQ 2.60GHz
GPU: Nvidia GTX 960

Version 1.4.0
Emulation settings: All Default 
Video Plugin Settings:
- Enable 8-Bit Textures checked
- D3D11
- Resolution 3x
- Bilinear (Forced)
- CRC Hack Full (safest)
HW Hacks:
- Skipdraw 1
- Alpha Stencil checked
- TC Offset X: 0000
- TC Offset Y: 1000
- Enable FXAA

Really wanted completion on this run, please help if you have any suggestions...I know it usually depends on PC build and settings so milage varies

Current Cheats attached

Attached Files
.pnach   Xenosaga Ep.II Cheats EB39ABEC.pnach (Size: 3,05 KB / Downloads: 237)

Sponsored links

Upgrade to the latest dev build.
(01-24-2019, 03:49 AM)CK1 Wrote: Upgrade to the latest dev build.

Thanks, I tried it and the game is crazy glitchy. I loaded the save file and the character couldn't walk into a shadow cast on the ground by a building covering a large portion of the playable field. Started a new game instead and the beginning stage displaces the character into areas I can't get out of, there's a shadow across the ground following me, and the lights bloom and during battles the whole screen flickers when beam/light attacks are used. I tried tinkering with the settings and can't get it to work properly. Do you know a fix or something to disable in order to work like a stable build? I'm pretty much just using default settings plus these fixes
UPDATE: Got it to work by disabling cheats back on V1.4. Thanks for the help, I guess this is the fix for game function glitches not related to graphics. I an thrilled that I can finally play my favorite JRPG in HD!

Users browsing this thread: 1 Guest(s)