Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Yakuza emulation
#1
Hello everyone, I'm trying to emulate Yakuza, and even though I found some settings examples on the internet, I still can't come up with a definitive choice.
First of all, I'm playing from ISO (it's legal, I have the original game from which I made the disc image).
This is my rig:

i5 7600k
16GB RAM
GTX 1070

I have attached the speedhacks I'm using, but for the Video Plugin, different settings make different results.
   

These are the plugins I'm using
   

Now, with these settings of GSDX
   

...this is the result:
         


Now, if I enable the HW Hacks in GSDX, set Skipdraw to 1 and check the Alpha option, the result is this:

         

As you can see, with the skipdraw makes the game much clearer, at the cost of not having any light displayed. I think it's some kind of post-processing being disable, but I'm not expert. 
In the screenshot with the volcano theater, the setting looks very barren, while it should be vibrant with lights. So, what I'm asking is: is there a way I can turn the lights on without them looking that bad?

Are there any settings I missed?

Thank you in advance.
Reply

Sponsored links

#2
The PCSX2 version you're using is outdated now, download the latest git build here instead: https://buildbot.orphis.net/pcsx2/

Also, make sure you switch to the OpenGL renderer since you own an Nvidia card. IIRC, the "Merge Sprite" option in the HW Hacks section of GSdx sometimes helps with this (see how it looks on 1.5 before you apply any hacks however)
Reply
#3
(04-08-2018, 10:08 PM)CK1 Wrote: The PCSX2 version you're using is outdated now, download the latest git build here instead: https://buildbot.orphis.net/pcsx2/

Also, make sure you switch to the OpenGL renderer since you own an Nvidia card. IIRC, the "Merge Sprite" option in the HW Hacks section of GSdx sometimes helps with this (see how it looks on 1.5 before you apply any hacks however)

Thank you for your answer. I'm now using the latest version, as you said, and this is how it looks without any hacks, 5x native resolution, Bilinear (forced excluding sprites), and High blending accuracy:

   

The game seems to have a little bit of stuttering, which didn't have previously, and the bloom from the lights seem to have some transparency issues which are not really perceivable from the image, but it's clear when I'm moving.

If I set the Merge Sprite option, there is no real difference, maybe the bloom from the lights it's just a little more crispy but I'm not sure.

EDIT: I also forgot to mention a slight input delay, which was present even in the previous version.
Reply
#4
Try one of the Half-Pixel Offset options in the HW Hacks section.

As for the speed issue, you can turn down Blending Accuracy but you may then be missing certain post-processing effects. Maybe turning the resolution to 4x native will be enough to get the speed back - I don't render any higher than that on my 1070 anyways Wink
Reply
#5
(04-08-2018, 11:03 PM)CK1 Wrote: Try one of the Half-Pixel Offset options in the HW Hacks section.

As for the speed issue, you can turn down Blending Accuracy but you may then be missing certain post-processing effects. Maybe turning the resolution to 4x native will be enough to get the speed back - I don't render any higher than that on my 1070 anyways Wink

4x seems smoother, thank you.

About the Half-Pixel Offset, ir produces this glitch right here; different options in the Half-Pixel Offset produce the same lines although a little different in appearance.

   

EDIT: Setting the Skipdraw to 2 removes all the lights altogether, just like when I set it to 1 on the previous version.
Reply
#6
Oh yeah, don't use that then I forgot about that.
Reply
#7
I was thinking that maybe the TC Offset option might help here, but I have no idea what I should put in the fields...

EDIT: I found this old image I had saved from 4chan some time ago. 

   

I set that to 178 as in the image and the bloom looks a little better, I think. Problem is, I'm still getting that weird transparency thing that is distinguishable only when moving. I'll try to make a video and post it here.
Reply
#8
Here is the video showing the glitch I was talking about

https://youtu.be/ck3_GB7SYOM

EDIT: also, there's this weird pose the main character has. I don't know if it's an emulation issue, or if it's the game itself.

   
Reply
#9
Any internal resolution enhancement over native on Yakuza 1 (and I think 2 if I remember correctly) will cause various visual issues.

The line issue I think will go away or be less noticable if you change the texture filtering to something other then bilinear (forced). Different settings of this and half pixel being the setting I eventually went with.

Skipdraw just messes with too many things to really be helpful (unless there is some odd skip draw setting I never found)

Also there are some odd poses in this game that are harder to notice when running on a PS2 and a CRT tv so that one looks pretty legit for this game.
Reply
#10
(04-09-2018, 06:31 AM)TkSilver Wrote: Skipdraw just messes with too many things to really be helpful (unless there is some odd skip draw setting I never found)

I'd like to know if one could implement a 1-5 and 45-50 skipdraw wherein 6 to 44 remains unaffected.
Reply




Users browsing this thread: 1 Guest(s)