Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Yakuza game is super blurry. Any way to fix it?
#1
I recently bought Yakuza 3 for the PS3 but I wanted to try Yakuza 1 first, so I bought that one too. Now I made an iso of it to play on my PC with the emulator, but I noticed it's incredibly blurry in some scenes. Searching the forums it seems to be a common problem, but I don't know if it can be solved somehow. If I press F9 to switch to software renderer and then again to return to hardware it goes away or gets reduced for a while, so it's just a matter of removing the blur effect completely to make the game more enjoyable. I know some games had those effects removed, like Okami and a few more, would it be possible to make a patch to get rid of the blur effect completely? I could play it on my PS2, but I'd rather play it on PC with savestates, faster loading and better graphics, but the blurriness is really killing it for me.

I know that the effect on the real PS2 is used to give the game that cinematic "out of focus" effect for some cutscenes, so it's really not very important. Could there be a way to have the emulator not render that effect altogether? Maybe with a patch or something like that?
Intel Core i5 3570K | Gigabyte GTX560Ti 448 | 8Gb Corsair Vengeance DDR3 | AsRock Z77 Ex4 | Windows 7 x64

Sponsored links

#2
I believe that the skipdraw hack was designed specifically for these kinds of effects. Sadly I've never had to use it so I'm not sure exactly how to set it for this game.

Wherever you have your ini files located, open up GSDx.ini and add the line "allowHacks=1".

Open up the graphics plugin configuration in PCSX2 and then change the value for skipdraw till the effect is removed.
#3
(04-15-2011, 01:24 AM)Koji Wrote: I believe that the skipdraw hack was designed specifically for these kinds of effects. Sadly I've never had to use it so I'm not sure exactly how to set it for this game.

Wherever you have your ini files located, open up GSDx.ini and add the line "allowHacks=1".

Open up the graphics plugin configuration in PCSX2 and then change the value for skipdraw till the effect is removed.

Thank you. I heard about this "skipdraw" feature, but I never found it. Now I know it has to be manually enabled in the INI. Will update this post after messing around with it, let's see if it fixes the problem.


Skipdraw to 1 with Alpha Hack pretty much completely fixes the graphics in this game.

In very rare occasions the screen will become blurry, but just press F9 a couple of times (to switch back and forth from software mode) and the blur 99% of the time will go away in hardware mode. There will be some minor graphical defects like the ring of Yumi appearing black or the monitors in Kage's lair not showing anything, if you notice some details missing just press F9 to see them in software mode. Not perfect, but much better than getting eye strain by looking at those terribly blurred graphics.

I think this way the game is 100% playable, I'm at chapter 8 now (out of 13) and so far the only problems have been the ones mentioned above, some details missing and the occasional persistent blur that most of the time goes away by pressing F9 a few times.
Intel Core i5 3570K | Gigabyte GTX560Ti 448 | 8Gb Corsair Vengeance DDR3 | AsRock Z77 Ex4 | Windows 7 x64
#4
I'm playing Yakuza 2 and running into a very similar issue in which cutscenes (including the cutscenes that play before fights) that the game is rendering in real time have an obscene amount of blur. Strangely enough, I didn't run into this issue in Yakuza 1.

Setting skipdraw to 1 and enabling alpha hack did not fix the blur for me. I tried skipdraw settings 1-10 and while in some cases the blur would be eliminated however, it would also stop rendering different parts of the character models.(behold, the horror unleashed by skipdraw 5)

Switching from Hardware to Software rendering fixed the blur also, but at the cost of FPS which caused audio bugs. Help would be greatly appreciated.
#5
The most recent post in this thread is more than 8 months old. Please create a new thread and refrain from posting in threads older than 8 months in the future. Please also review the forum rules. Thank you.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go




Users browsing this thread: 1 Guest(s)