Zone of the enders 2 cutscene crash
The game runs at standard 50fps on every stage thanks to a basic speedhack, but I've hit a brick wall with cutscenes crashes.

Near the end of each cutscene made with the in-game engine, not the anime ones, the game crashes. This would not be a problem if, as I've done till now, I could just skip all the cutscenes, but the last one, just after the last battle, is impossible to skip, and freezes my game.
The audio keeps stopping and playing at intervals of 2 seconds each with massive tearing during the playback, but the video is stuck on the same 2 frames, going back and forth.
New cutscenes don't start and the game doesn't unfreeze until I manually restart it.

I've already tried setting clamping to full, disabling every speedhack, enabling superVU instead of microVU and even using the frame skip option to jump over the frame that freezes the game, but nothing worked.

Any solution?


With rev5023 (I was using this rev before 1.0.0 was released) the final cutscene doesn't crash, and althrough the game slows down in many places even with the speedhack, the cutscene seems stable, if slow. Same settings were used.
Maybe the info can be useful to identify the problem with the new rev (5350), hope it helps.

Sponsored links

Fixed, can be closed.
Care to check a couple of builds from here, pinpoing where between r5023 and r5350 this was introduced? It would help debugging it alot.
[Image: newsig.jpg]

Users browsing this thread: 1 Guest(s)