Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
accelerate GSdx
#11
@123_qwe,

I think you release shift (or ctrl never remember). The dump is only 4 frames, I can't see the perf impact this way. You need to keep shift (or ctrl still not remember) pressed, before compression the gs dump must be at least 100-200Mo.


@tsunami2311

Could you please post your GSdx.ini file.
Reply

Sponsored links

#12
I think i over did it this time : http://www.filedropper.com/gsdx20150517135649gs Tongue2
Reply
#13
seriously what is the size of that dump?
Reply
#14
(05-17-2015, 12:39 PM)gregory Wrote: @123_qwe,

I think you release shift (or ctrl never remember). The dump is only 4 frames, I can't see the perf impact this way. You need to keep shift (or ctrl still not remember) pressed, before compression the gs dump must be at least 100-200Mo.


@tsunami2311

Could you please post your GSdx.ini file.

Code:
[Settings]
UserHacks_MSAA=0
UserHacks_AlphaHack=0
UserHacks_HalfPixelOffset=0
UserHacks_SpriteHack=0
UserHacks_SkipDraw=0
UserHacks_WildHack=0
UserHacks_AggressiveCRC=0
UserHacks_AlphaStencil=0
UserHacks_NVIDIAHack=0
UserHacks_DisableCrcHacks=0
UserHacks_round_sprite_offset=0
Userhacks_align_sprite_X=0
UserHacks_TCOffset=0
Adapter=10DE:11C0:26633842:A1
Renderer=12
Interlace=7
AspectRatio=0
upscale_multiplier=3
MaxAnisotropy=8
filter=1
paltex=0
logz=1
fba=1
aa1=0
nativeres=0
resx=1024
resy=1024
extrathreads=0
AnisotropicFiltering=1
ShadeBoost=0
Fxaa=0
shaderfx=1
shaderfx_conf=shaders/GSdx_FX_Settings.ini
shaderfx_glsl=shaders/GSdx.fx
UserHacks=1
and like mentioned earlier gsdx shader dont seem to work
Reply
#15
Do you still have the bug with
logz = 0
shaderfx = 0
UserHacks = 0
Reply
#16
Logz=0

make the lines less apparnt lines are no more black more like transparent and flicker

Shaderfx=0

has no effect as i said gsdx shaders dont work in opengl mode

UserHacks=0

has no effect

PCSX2 1.3.1-20150517130508 - compiled on May 17 2015
Reply
#17
There are some info printed (in the console?) of the feature enabled in GSdx-ogl. Something like that:
Quote:INFO: GL_EXT_texture_filter_anisotropic is available
INFO: GL_ARB_gpu_shader5 is available
INFO: GL_ARB_separate_shader_objects is available
INFO: GL_ARB_shader_subroutine is NOT SUPPORTED
Override GL_ARB_shader_subroutine detection (Disabled)
INFO: GL_ARB_shader_image_load_store is available
INFO: GL_ARB_explicit_uniform_location is available
INFO: GL_ARB_copy_image is available
INFO: GL_ARB_buffer_storage is available
INFO: GL_ARB_bindless_texture is NOT SUPPORTED
Override GL_ARB_bindless_texture detection (Disabled)
INFO: GL_ARB_clear_texture is available
INFO: GL_ARB_clip_control is available
INFO: GL_ARB_direct_state_access is available
INFO: GL_ARB_texture_barrier is available

Could you copy/past it?

Normally logz must be disabled at runtime because your GPU must support GL 4.5 (GL_ARB_clip_control).
Reply
#18
(05-17-2015, 04:51 PM)gregory Wrote: seriously what is the size of that dump?

2 gigabytes Blush

Hopefully it can be of any use.
Reply
#19
Code:
INFO: GL_EXT_texture_filter_anisotropic is available
INFO: GL_ARB_gpu_shader5 is available
INFO: GL_ARB_separate_shader_objects is available
INFO: GL_ARB_shader_subroutine is NOT SUPPORTED
INFO: GL_ARB_shader_image_load_store is available
INFO: GL_ARB_explicit_uniform_location is available
INFO: GL_ARB_copy_image is available
INFO: GL_ARB_buffer_storage is available
INFO: GL_ARB_bindless_texture is NOT SUPPORTED
INFO: GL_ARB_clear_texture is available
INFO: GL_ARB_clip_control is available
INFO: GL_ARB_direct_state_access is available
INFO: GL_ARB_texture_barrier is available

Your driver supports advance depth. Logz will be disabled
Reply
#20
@123_qwe,
3GH Haswell
=> 230 fps
=> nvidia option: +300 fps

Either the issue come from the Core. Or it requires a synchronization (mtgs waits). Those message are killer. Because PCSX2 asks GSdx to sync. GSdx ask the driver to sync. In short it is very slow.
Reply




Users browsing this thread: 1 Guest(s)