black screen: not updating

I just recently got PCSX2 0.9.9.r5096 to compile and run (with a bit of effort).

When running the screen opens but is black (does not update) except for the
"bilinear filtering - normal" message (which seems to work just fine). It does
not matter what I run. I test this using the "Reboot CDVD (full)"
option and attempt to view the boot screen. I can force an update by either doing
a "Pause/Resume" or by pressing "F9" and cycling between software/hardware
rendering. A single frame of graphics for that point in the boot sequence can be seen.
I've tried running some *.ELF tests and the result is the same. Sound is present however.
One can hear the boot sequence sounds.

Help appreciated

PCSX2 0.9.9.r5096 - compiled on Feb 15 2012
Savestate version: 0x9a060000

Host Machine Init:
Operating System = Linux 2.6.34-12-desktop i686
Physical RAM = 2985 MB
CPU name = Intel® Core™2 Duo CPU T6570 @ 2.10GHz
Vendor/Model = GenuineIntel (stepping 0A)
CPU speed = 2.093 ghz (2 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 0c08e3bd
x86EFlags = 20100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1

Installing POSIX SIGSEGV handler...
Mapping host memory for virtual systems...
EE Main Memory @ 0x20000000 -> 0x22884000 [40mb]
IOP Main Memory (2mb) @ 0x24000000 -> 0x24211000 [2mb]
VU0/1 on-chip memory @ 0x28000000 -> 0x2800A000 [40kb]
Reserving memory for recompilers...
SuperVU0 Recompiler Cache @ 0x0E800000 -> 0x0F000000 [8mb]
SuperVU1 Recompiler Cache @ 0x0F000000 -> 0x0F800000 [8mb]
Micro VU0 Recompiler Cache @ 0x3C000000 -> 0x40000000 [64mb]
Micro VU1 Recompiler Cache @ 0x40000000 -> 0x44000000 [64mb]
R5900-32 Recompiler Cache @ 0x30000000 -> 0x34000000 [64mb]
R3000A Recompiler Cache @ 0x34000000 -> 0x36000000 [32mb]
VIF0 Unpack Recompiler Cache @ 0x36000000 -> 0x36800000 [8mb]
VIF1 Unpack Recompiler Cache @ 0x38000000 -> 0x38800000 [8mb]
(GameDB) Database Not Found! [/usr/local/packages/emulation/sony/ps2/pcsx2/pcsx2.svn.021212.00/pcsx2-read-only/pcsx2/GameIndex.dbf]

Loading plugins...
Binding GS : /usr/local/packages/emulation/sony/ps2/pcsx2/pcsx2.svn.021212.00/pcsx2-read-only/pcsx2/plugins/
Binding PAD : /usr/local/packages/emulation/sony/ps2/pcsx2/pcsx2.svn.021212.00/pcsx2-read-only/pcsx2/plugins/
Binding SPU2 : /usr/local/packages/emulation/sony/ps2/pcsx2/pcsx2.svn.021212.00/pcsx2-read-only/pcsx2/plugins/
Binding CDVD : /usr/local/packages/emulation/sony/ps2/pcsx2/pcsx2.svn.021212.00/pcsx2-read-only/pcsx2/plugins/
Binding USB : /usr/local/packages/emulation/sony/ps2/pcsx2/pcsx2.svn.021212.00/pcsx2-read-only/pcsx2/plugins/
Binding FW : /usr/local/packages/emulation/sony/ps2/pcsx2/pcsx2.svn.021212.00/pcsx2-read-only/pcsx2/plugins/
Binding DEV9 : /usr/local/packages/emulation/sony/ps2/pcsx2/pcsx2.svn.021212.00/pcsx2-read-only/pcsx2/plugins/
Plugins loaded successfully.

(SysExecute) received.
HLE Host: Will load ELF:

HLE Notice: ELF does not have a path.

Initializing plugins...
Init GS
Init PAD
Init SPU2
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 2) (0 sectors)
(IsoFS) Block 0x10: Primary partition info.
(IsoFS) Filesystem is ISO9660
Opening USB
Opening FW
Opening DEV9
Opening Memorycards
McdSlot 0: /home/rtwas/PCSX2/memcards/Mcd001.ps2
McdSlot 1: /home/rtwas/PCSX2/memcards/Mcd002.ps2
Plugins opened successfully.
Allocating host memory for virtual systems...
R5900 RAM copy @ 0xA23EF000 -> 0xA43EF000 [32mb]
R5900 RAM LUT @ 0x9FFAF000 -> 0xA23EF000 [36mb]
EE/iR5900-32 Recompiler Reset
iR3000A Recompiler reset.
Resetting host memory for virtual systems...
Bios Found: USA v01.60(07/02/2002) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
IOP resetting main memory...
Generating SSE-optimized unpacking functions for VIF interpreters...
VIF SSE-optimized Unpacking Functions @ 0x9F95D000 -> 0x9F96D000 [64kb]
Unpack function generation complete. Generated function statistics:
Reserved buffer : 8192 bytes @ 0x9F95D000
x86 code generated : 4294959618 bytes

(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
COP0_TLBWI 0:0,70000000,80000007,7

Sponsored links

What is your GPU? Intel? In this case it probably does not support opengl properly...

Edit: by the way it might be more useful to see zzogl log file.

Users browsing this thread: 1 Guest(s)