[bug report] God of war 2 please help!
Hi everyone... im having a problem with my gof of war game.
i can' save or load by normal means.the game just freezes on me Sad
so i used the save state slot option and it worked just fine.
anyway, here is my problem in short: before the barbarian with the Hummer i couldnt upgrade my weapons, everytime i tried it the game freeses and the emulator crashes. after beating the barbarian i was able to upgrade my blades but they disapeared Ohmy
another problem is that the game just freezes again but doesnt crash wheneve i try to get out of that area. all i can see is a frozen picture of kratos and a "Loading" flashing at the bottom of the screen. waited for about 10 minutes but nothing happens. please help.

im using the latest pcsx2-r1888 version with the GSdx-r1076m graphic plugin.
tried with 0.9.6 version but cant load or save either and the same problem still goes on Sad

Attached Files Thumbnail(s)

Sponsored links

Come on guys... cant anyone help me with this...im getting alot of frustration here..after finally being able to play this game on my pc im stick with this. please help Sad
use GSdx-r1873,search the site for it
thanks for your reply enosrasun.. i tried GSdx-r1873 with all versions SSE2, SSE3, SSE41, but still having the same problem Sad
the screen wont go past the loading part, and the weapons doesnt appear when i upgrade.

anyone else has any more ideas on how to solve this issue??!!!!!!!!!!!!!!!!!!!!
Bug still exists, pcsx2-1.0.0-r5350, God of War II PAL, CRC = 0x44A8A22A. Problem with adding or upgrading weapon on the island with sisters of fate (game cant load checkpoints and locations, infinite "Loading" flashing). Of course I can avoid weapons' upgrading, but how can I avoid giving me Barbarian's Hammer? With this hammer I cant leave location (after defeating Barbarian's king) or die - game begin to "loading" forever. . Is there any patch to fix that? Simple "NEVER ACCEPT Barbarian's Hammer" will work, I thinkSmile
P.S. Saves in game are not working too, but savestates were quite stable so farSmile Sometimes I load from last checkpoint to reset all possible bugs in savestates.
Sorry for my not native englishSmile
Configuration: Windows 7x64, Core i7 3.4x4.4ghz, Geforce 470, 8gb ram
All speedhacks disabled, gsdx AVX, directx 11 hardware, HW-hack - aggressive CRC.
Attached buggy screenshots:
    infinite loading
    no blades
    no blades 2
    no bane

Users browsing this thread: 1 Guest(s)