can't launch pcsx2
hello all members, i'm newbie here and i need help, i recently installed pcsx2 version 1.2.1 with the updates of directx and microsoft visual c++ checked, after the installation was finished i double clicked the icon on the desktop but i got a message saying pcsx2 exe stopped working with suggestions to check for online solution or close the program, running as administrator didn't solve the problem, the problem signature is as follows:
Problem Event Name: BEX
Application Name: pcsx2-r5875.exe
Application Version:
Application Timestamp: 52ef990f
Fault Module Name: MSVCR120.dll
Fault Module Version: 12.0.21005.1
Fault Module Timestamp: 524f7ce6
Exception Offset: 000a46bb
Exception Code: c0000417
Exception Data: 00000000
OS Version: 6.1.7601.
Locale ID: 2049
Additional Information 1: 0210
Additional Information 2: 0210bb20c0b54c7182e4568d071e2a56
Additional Information 3: aa79
Additional Information 4: aa793ad46062e231c7c9e4c9c3bd7a51

Read our privacy statement online:

If the online privacy statement is not available, please read our privacy statement offline:

Sponsored links

BEX event = Data Execution Prevention error do you have Data Execution Prevention enabled in windows?

right click on my computer
go to properties
click on advanced system settings
under performance, click settings
click the Data Execution Prevention tab

If it on turn off see if it happens still, could also add pcsx2.exe to the trusted list and see if that helps
Make sure you install the visual studio runtimes correctly.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
thank you friends for yr reply, i tried to turn off DEP as you told me but a message popped that this program must run with DEP enabled and would'nt allow me to add it to exception list. i also tried to shut off DEP from command prompt and i succeeded but when i double clicked pcsx2 icon the same message appeared. i spent the hole day trying to figure out the problem with no benefit.
not sure then, i know some one else had similar issue not sure if it was ever fixed. all know is BEX is DEP error weather something else i causing there i dont know.

you can try this

This will auto install all known VC ++ with current versions. though not sure if it will help or if it is VC++ files causing the dep error. but VC++ file is mentioned in that error. so it worth a shot.
( that program will uninstall ALL VC++ on the system then INSTALL all know VC++ with current version 2004-2013) been using it for years to maintain VC++ instead of manual finding and installing them all
I remember having troubles (long ago) with VC++ version from the official link. Had to get the last version directly from MS and Install both, the 64 and 32 bits version.

Edit: IIRC the message was about newer version already installed in the system. Probably the problem was lacking the 32 bits version (in my case). Anyway, reinstalling everything resolved the problem.
Imagination is where we are truly real

Users browsing this thread: 1 Guest(s)