cheat engine: armored core silent line
#1
ok, i give up. this game is 99% untouchable by both gameshark codes AND cheat engine.

earlier tonight i was playing king's field 4 and hacked the hp/mp, gold, phys/mag strength values just fine and could even close out pcsx2 completely and load it back up and have the same exact values for my cheat table.

but the one and ONLY thing i can touch with cheat engine in armored core silent line (and likely all other ps2 armored core games) is the money value for the shop.

oh, sure, i can find the AP values (2 and 4 byte iirc) but i can't change or freeze them. if i freeze them they keep going down when i get hit. changing them does nothing.

what the hell did From do to protect these armored core games? they didn't put such absurd protection on any of their ps1 titles. didn't put any protection like this in king's field 4...or eternal ring...or other ps2 games they made...but AC? oh no...you can't touch ps2 armored core in ANY way except the money value.

the pnach thing for pcsx2 doesn't work and i even tried using gameshark before coming to post this and that didn't work either...

and for anyone who may reply... i'm asking for help with either gameshark codes or cheat engine specifically. not something like "artmoney".

Sponsored links

#2
https://forums.pcsx2.net/Thread-Post-you...#pid338112
#3
You have to do something with cheat codes by converting gameshark/codebreaker/action replay codes into RAW codes with omniconvert, no need to find its mastercode. Then, apply RAW codes into such PCSX2 cheat code format. Then, find its CRC code of the game title and save it under [CRC-code].pnach into cheat folder inside PCSX2 directory.
AMD Ryzen 3500X 3.5Ghz (OC'ed to 4.0Ghz)
16GB DDR4 2667Mhz RAM
AMD RX 480 8GB GDDR5.
240GB SSD
Gigabyte Aorus B450i ITX mobo

*PCSX2 1.7.0 64-bit tester
#4
i would like to know where those codes came from because i usually go to gamehacking.org for such cheats and those are the codes i was trying that kept failing to work.

"V6 on code sites"

what code sites? none i've seen match these when run through omniconvert. i mean, thank you, but what the heck?

edit: nope, scratch that. pcsx2 detects the file but says "0 cheats loaded". pnach file isn't working either.

from the console:

Found Cheats file: 'B8BFF0B1.pnach'
comment: Cheats i'll need to brave AC3WackoL!
Loaded 0 Cheats from 'B8BFF0B1.pnach' at 'C:\Users\*****\Desktop\Video Games\Emulation\full romsets\PS2\pcsx2-v1.7.0-dev-490-g05f20fa66-windows-x86\cheats'
Overall 0 Cheats loaded


and i tried that to no avail because apparently i didn't have the correct codes or something...
#5
I know this thread is 2 year old.
for faster scans, set the start at 20000000 and stop at 30000000
here they are most of values from the game

in order to find HP in game you need to be on a mission or arena
look how much HP do you have, pause it and multiply by 4 that value then search it at 4 byte scan

some values are "hard placed" like ammo dmg at 2 bytes scans, and reload time at 1 byte scans.


I did a cheat to equip every optional part on ac (including OP-intensify)
here is the raw codes:
2156A290 000FFFFF <-AC 1
2156A590 000FFFFF <-AC 2
2156A890 000FFFFF <-AC 3 (i dunno, maybe cuz memory address order)

pnach type:
patch=1,EE,2156A290,extended,000FFFFF
patch=1,EE,2156A590,extended,000FFFFF
patch=1,EE,2156A890,extended,000FFFFF

if you want an explanation, the opt-intensify when you equip it, has a value of 32767
op-s-scr 1 pos 1 at shop
op-e/scr 2 pos 2 at shop
op-s/stab 4 pos 3 at shop
op-e/cnd 8 pos 4 at shop
...
op-intensify 32767 pos 16 at shop

the only thing is you shouldnt unequip/sell the OP-intensify it will crash the game
this looks like a bug/glitch caused by that part cuz when you equip it it takes all the space from optionals
allowing this cheat to happen
#6
The most recent post in this thread is more than 8 months old. Please create a new thread and refrain from posting in threads older than 8 months in the future. Please also review the forum rules. Thank you.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go




Users browsing this thread: 2 Guest(s)