configuring graphic plugin crashes pcsx2 1.2.1

Any time I try and configure the video plugin (GS) on pcsx2 1.21, it crashes and I get an error saying pcsx2 -r5875 has stopped working. I can't manipulate the graphics settings at all. Any idea why this is happening? Is it just my computer? Running Intel q8200 quad core 2.3 ghz, with Nvidia 9500 gs graphics card (DX10), with 8 gigs ram, under Windows Vista. I updated my graphic driver and am still having this problem. Any solution to this?

Sponsored links

Do you get the more info button in the crash dialog? If so, can you please show what it says?
[Image: XTe1j6J.png]
Gaming Rig: Intel i7 6700k @ 4.8Ghz | GTX 1070 TI | 32GB RAM | 960GB(480GB+480GB RAID0) SSD | 2x 1TB HDD
No, it doesn't provide any more information. Sad
I'm wondering if it's because I don't have dx11 installed...

My graphics card is only dx10 though.
You can try to update directx, it´s worth a try
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Well, looks like updating windows gave me directx11, and that solved the problem. Tongue

Too bad, I can't make use of any of these features, as I'm running it on an old pc. Oh well, time to buy a new one maybe.
This is my problem too. I tried to update my directx to directx 11.the installation of directx 11 was successful but when i checked "dxdiag" it still directx 10. please help
That doesn't really matter.
[Insert Witty Sig Here.]
The most recent post in this thread is more than 8 months old. Please create a new thread and refrain from posting in threads older than 8 months in the future. Please also review the forum rules. Thank you.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

Users browsing this thread: 1 Guest(s)