(error 5: access is denied.)
I'm not sure where to post this, as I just got PCSX2 today, but When I tried to make changes to the emulator (like changing the resolution), the Program Log would read the following:

[wx] can't commit changes to file 'C:\Users\USER\Documents\PCSX2\inis\PCSX2_ui.ini' (error 5: access is denied.)
[wx] Failed to update user configuration file.

This happened before, and I uninstalled and reinstalled then looked for a fix, and the one I found said to just install PCSX2 to a folder not in the C:\Users folder, so I made a new folder with path C:\PCSX2\ and installed the emulator there. However, it still comes up with this error message.
I looked, and the file C:\Users\USER\Documents\PCSX2 was created again, despite me having PCSX2 installed to C:\PCSX2\
I also looked in C:\PCSX2\ and the file is still there, but it doesn't have the same contents as the file in the Users directory.

Contents of C:\PCSX2\PCSX2 1.2.1\
bios (folder)
Cheats (folder)
Docs (folder)
Langs (folder)
Plugins (folder)
cheats_ws.zip (.zip)
GameIndex.dbf (DBF File)
pcsx2-r5875.exe (Application)
Uninst-pcsx2-r5875.dat (DAT File)
Uninst-pcsx2-r5875.exe (Application)
w32pthreads.v3.dll (Application Extension)
w32pthreads.v4.dll (Application Extension)

Contents of C:\Users\USER\Documents\PCSX2\
bios (folder)
cheats_ws (folder)
inis (folder)
logs (folder)
memcards (folder)
snaps (folder)
sstates (folder)

I'm not sure why the second folder was created. I couldn't find any way to fix other than reinstalling to another folder, which I already tried. Is there anything I'm doing wrong, or another fix entirely?

Sponsored links

This is a windows protection thing, it's a paiun in the ass. make sure you put a file in your pcsx2 folder (with the exe) called "portable.ini" then run pcsx2, this will make all the configuration stuff go under the pcsx2 folder instead of in your documents.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
It's still interesting that writing to documents folder fails or? That's just exactly the place where applications should write stuff. (well at least in the users directory)
It is odd still, you'd think that would be considered "safe" by windows, which is why we put it there in the first place
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Where is the portable.ini file? Is it already in one of my files somewhere?
No. Just create a new text file and rename it into "portable.ini". Please ensure that you are actually changing the file ending. Windows can prevent you sometimes from changing endings and you end in something like "portable.ini.txt" which will not work
or you can choose in compatibility to "Run this program as administrator"

Users browsing this thread: 1 Guest(s)