ffx mac help please :)
ok im probably making this way more complicated than it needs to be, i apologize if i am:

hi, ive been trying to get ffx to play on my mac but i cant seem to get it to work right, could someone help me please? Smile

i dont know that much about using pcsx2 and iv looked all over for help for this problem so if im just posting something that has already been solved, could you please post a link to the thread that has the solution? im encountering the "auron look" freeze that at the beginning of the game during the movie when sin destroys zanarkand and tidus is hanging from the beam the screen goes white and just freezes. iv looked around and ppl have said that a possible solution to this is to run the ffx hack, which if i understand right you get to through gsdx graphics plugin. my only problem is i have tried through this site and others to get a version of gsdx on my mac, but when i put it in my plugins folder pcsx2 seems to not recognize it, because when i go to config>configure and click the dropdown menu for graphics only zzogl is there. gsdx seems to be a .dll file and all the other files are .so files so my question is threefold:

1. is there a gsdx file that can run on mac, that i have been unable to find or am i just too stupid to see the easy way to get pcsx2 to run the gsdx i have through some other means?

2. if im dead wrong about ffx hack being through gsdx (like i said, i dont know that much about pcsx2, im just some kid who cant take his ps2 to college but would still like to play ffx to distract him from term papers Smile ) , could someone please tell me the correct way to activate/run/whatnot the ffx hack?

3. does anyone know any other way to get past this particular problem in the game? i have read that some people suggest to play through it on the ps2, save it to the memory card, and put that save file on the computer but i havent the slightest idea how to do that and id like to actually know how to fix the problem so if something should go wrong i dont have to wait til semesters over to get access to my friends memcard ( i lost mine Sad )

thank you so much for any help!!!! Laugh

oh and im on a mac with mac osx version 10.5.8 with an intel core duo (im not too sure if that info is helpful or not, but iv seen on other threads ppl ask specifics about the computer) and the plugins im using are:

graphics: ZZ Ogl 0.19.195
first and second controllers: ZeroPAD 0.3.0
dev9: DEV9null driver 0.4.0
usb: USBnull driver 0.6.0
sound: i seem to have an option between (SPU2null 0.8.0) and (P.E.Op.S SPU2 SDL 1.9.0), would either of those make a difference? i dont think it would, but idk maybe it does
cdvdrom: again an option between (linuz iso cdvd 0.9.0) and (CDVDnull Driver 0.6.0)
firewire: FWnull Driver 0.5.0

thanks again!

Sponsored links

GSdx is a directx plugin so it's only available on windows. Probably the easiest way to go for you would be the memcard route, there are a couple of guides on the net how to extract your saves from ps2.

Other than that, I don't think i've ran into this problem myself so it's not simple to fix if i can't debug it Smile
i actually have a save file right after that if you are still having this problem

i had this same problem and searched for hours for a save file then just ended up making my own

Users browsing this thread: 1 Guest(s)