.hack infection optimal settings [question]
Hello. First of all, I apologise if this is the incorrect section, but apart from general discussion, this seemed the best place for it.

I've recently downloaded PCSX2 0.9.6, and I'm trying to run .hack infection on it, the first game of the series. The framerate is sticking to 30 FPS, which is unpleasant, since the audio chops around and everything is rather slow.

My rig is composed of a Intel core 2 duo 3.0 GHz, a brand new Geforce 9500 GT, and 1GB of ram. I had 2, but one burned, and had to be thrown away. I'm running a fresh format of windows XP, service pack 3, and I've updated DirectX, or else the emulator wouldn't be running. I believe all of this is fairly enough to run games, as mentioned in the needed specs to run the emulator.

I'm using the GSdx 890 plugin, shader 3.0, 800x600 internal res, everything else as it was. The game is running on a CD. I've also tried ZeroGS to no avail.

The game also has this mind-bogging tendency to crash when I enter "The World". Mind-bogging because I can only think of this as a 3D error, but the first cutscene is rendered in 3D via game engine, and it plays fine. I'm also looking for a solution to this.

So, considering you're still reading (and thank you for that), I'd like to know what else I can do, what other things can I try to make the game run faster, and perhaps fix the crash, what else I need to update, or if I simply can't run the game at all. I'm willing to try different things for this game, since it's one of my firsts and I've grown very attached to it, but my PS2 has recently been sent for repairs.

Once again, thanks for reading.

Sponsored links

Fetch the beta PCSX2 and the beta plugin pack, set it all up, and then try again.
Also make sure to use the microVU recompiler (you'll find it in the options) instead of sVU.
A bit slower, but should fix the crashes.
The game is marked as Ingame in the compatibility list, that means that it crash, have bugs, errors... It isn't fully playable.
Just do what Rama says, it should work better, but don't expect much of it. It isn't a problem of your PC.
Athlon x2 240 2.8 GHz / HD5670 512MB / 2 GB RAM DDR2-800 / Windows 7 x64

"Pardoning the bad is injuring the good."
After doing everything rama said, I still have problems like yours. Then, and I don't know why, but it worked for me, I changed the graphic option from Direct X 10.0 (hardware) to Direct X 10.0 (software) and my fps jumped to how it was on my PS2. Everything runs fine, but the only problem I have now is the voices are still slow/repetitive, but that's probably because of my unimaginably horrible 'graphics accelerator'.
I've installed the beta and the plugins. I'm happy to report that the game now runs in flawless 50 FPS per second even in 3D, and looks a little better than before. Unfortunately, I haven't been able to find this microVU thing, so the game is still crashing at that spot. If you can tell me where to find it, exactly, I'd be happy, because I don't see any "options" option.

But thanks. You really, really, REALLY helped things move along.

As for changing to DX10 mode, I'm afraid I can't, since this is windows XP. I had windows 7 just a while back, but I had to format since, well, after four boot ups, the windows would simply be stuck at the "Welcome" screen. It was a pity since I really liked it.

And, well, I'm aware that it's not a green game, but it seems to be running so well now, it's difficult to imagine why it would just crash randomly.

Oh, and the multi thread option as well.
That did the job. Game now seems to work normally, though FPS in 3D enviorments is now on the 35-37 border, trying desperately to reach for 40 at some spots. Doesn't seems to have any problems visual-wise, except for a lack of antialiasing. FPS at menu screens is unchanged.

But it works. Thanks, you guys really helped. Wish I could offer something more than my thanks, though.

Edit: I've been playing around with the speed hacks, and many of them make the game run at 60+ FPS without any problems. If only there was a way to cap that FPS at 60, the game would be running flawlessly now.
Uh... set the frame limiting to "Limit"?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Uh, right... sorry. I turned that off to see if any improvement would happen, and forgot to tick it back on.

The game seems to work fine on fields and dungeons, but on cutscenes and in town, it drops to 30 FPS. Still, problem solved. Thanks.
Just a quick question, I've been reading that dualcore processors like mine support this SSSE3 thing. Now, I'm not sure what it is, but apparently it gives you better performance. I've been using SSE2 up to now.

So, I've read on the wiki that SSSE3 is supported by core 2 duo processors, I set up the plugin, it reports that it should work (notice the should), then, when I select the game image, the folowing messages pops up:

This CPU does not support SSE 3.01.
GS plugin failed to initialize. Error Code: -1

The messages repeat once, and then stop. Nothing. What am I doing wrong here? Huh

Edit: A quick look into system properties reveals that this is a Intel Pentium D CPU 3.00 GHz 3.00 GHz. My only guess is that I've been fooled all along and this fake duo isn't supported?

Edit Edit: Cpu Config in PCSX2 shows that the features for my processor are MMX,SSE,SSE2,SSE3.


THERE'S THE SSE3 BLIMER AGAIN. I'm confused here. The config says it's a feature, yet the plugin says it's not supported. What am I doing wrong here?

Users browsing this thread: 1 Guest(s)