in pcsx2s config dialog, configuring "ZeroGS KOSMOS OpenGL 0.96.7" results in a segfault. I compiled pcsx2 and the plugins from svn, its running on ubuntu intrepid amd64.
The plugin does not work on the precompiled version (found in this forum) either.
Here is all it gives me:
Quote:failed to open inis/zerogs.ini
failed to open inis/zerogs.ini
Segmentation fault

I tried creating the inis/zerogs.ini myself, but that does not change anything.

Sponsored links

Maybe you forgot to settle up permissions?
looks like it, since no plugin seems to be able to write inis.
the thing is, pcsx2 has the same owner as the inis directory, which is drwxr-xr-x
Well, r-x -- allow to read and execute. You should have rwx.
I am also running Ubuntu Intrepid x64, I compiled pcsx2 from svn HEAD and when trying to configure it I get exactly the same error message.
I tried giving full permissions recursively to all the files and directories under bin/ but nothing changed. I also changed the owner and group of all the files to my user/group.
Any clues? Maybe a recently introduced bug in SVN?

By the way, I give you a suggestion, I think you shouldn't expect users to run the program as root by default or to give the files more permissions than the really needed "just in case", maybe in windows world there is not much attention put into that, but in Linux (unix) it's a no way to go.

Thanks for all!
Please, state number of revision! There was issue 55 have failed to read message from r560 to r568, but it was fixed.
I checked out the svn of pcsx2 r396. I realize that it's not only with this plugin but with all of them. Non of them is able to create its ini file.
r396? It is October version? I really don't remember their bugs.
It's the one you get when you checkout like

svn co

Which version do you suggest? From where do I check out a copy?

By the way, running strace I found that the bug is produced by trying to open the ini file without attaching it's full cwd path before it. This should be done in GSmain.cpp in a ifdef __LINUX__ macro directive, but I doesn't happen.
I will horribly hard code it into the code and I'll tell you if that worked.
Well, it's just normal situation. But current version could be found at

svn checkout pcsx2-read-only

Users browsing this thread: 1 Guest(s)