Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[macOS] P.R.O.M. - PCSX2 Running On Mac (New wrapper for 64-bit macOS)
#1
Hello all!

Of course, today is my first post on this forums as well as my first day of this new account. Regardless, I want to present the new wrapper created for PCSX2 to work properly on Mojave and possibly above. I only tested this on Mojave 10.14.5, so I have no idea if it works below that since the wrapper is ran on 64-bit wine engine instead of 32-bit. I also have no idea if this also will work on Catalina beta, either... and I probably will not test it on Catalina for now. And of course, this port isn't perfect but it works.

And yes, I've tried options here on the forums to get PCSX2 work on macOS, such as PCSX2-CE. Just didn't work as it should for me. And indeed, since Mojave is the last OS to allow 32-bit applications and Catalina no longer allows 32-bit, I've created wrapper to work with Mojave and above, so... HA IN YOUR FACE, APPLE!


P.R.O.M. - PCSX2 Running On Mac (New wrapper for 64-bit macOS)
Created by Amarante (firelad97)

This wrapper is intended to work on 64-bit versions of macOS! Untested on Catalina and 32-bit versions, but should work.

Download P.R.O.M. Installer here!
DMG Installer 2.54 GB on Mega

Make sure to drop your BIOS files inside PCSX2/bios folder found in your Documents folder (not inside package contents!) after launching PROM.
WARNING: DO NOT SELECT OPENGL, SOFTWARE OR HARDWARE, FOR GS RENDER!! This possibly will crash PROM or will not load games at all. This is due to the removal of OpenGL support on recent macOS versions.

Updating PCSX2 to the latest development versions should be simple as downloading it and move respective folders and files to Documents/PCSX2 and PROM.app/drive_c/Program Files (x86)/PCSX2.

PROM runs on PCSX2 1.4.0 and 64-bit wine engine, so ideally, this should run on almost all 64-bit versions of macOS up to Catalina. However, I have no idea if PROM will run on Catalina yet, I will get to test it later. Also, everything is already pre-configured for you so no worries if First-Time Configuration didn’t appear.

Getting “PROM.app is damaged and can’t be opened. You should move it to the Trash.” error message? No worries! This is due to how Gatekeeper work on recent versions of macOS, can be easily fixed:
  1. Open terminal.
  2. Enter this command:
    Code:
    sudo spctl --master-disable

  3. Enter your computer administrator password when prompted. It hides the password for a security reason, not even asterisks.
  4. Open PROM.app and click “Open” when asked if you’re sure.
  5. It is safe to close PROM.app now and…
  6. …enable Gatekeeper again by entering this command in the terminal:
    Code:
    sudo spctl --master-enable

  7. Re-enter your computer administrator password if prompted again.
  8. PROM.app should open just fine now.
If there are any issues associated with the wrapper… please let me know as soon as possible and I will do my best to help you out. Smile
Reply

Sponsored links

#2
Hello,

I am new to PCSX2 but I followed the intructions above. I downloaded, copied the app to applications folder, opened package contents, added my PS2 bios file and I got the below message when opening the app.

[Image: view?usp=sharing]

'"PCSX2" is damaged and can't be opened.
You should move it to the Trash.'

I have tried CTRL and Click to open. and Right CLicking and selecting Open but neither worked.

Hoping you can help as I want to re live suikopden 3!

Thanks,

John
Reply
#3
(07-10-2019, 02:41 AM)tokaimaster Wrote: [Image: kUhZYRmCg1GKhLrHJ2ZfHTlV2D_70jI23_3hE36N...3360-h1724]

Try this:
  • Open System Preferences
  • Open Security & Privacy
  • Make sure General tab is toggled
  • Click "Allow..." for PCSX2 that appears below "Allow apps downloaded from:"
Otherwise, I will need to test this on a virtual machine ... because I have no idea why it didn't work for you. There might be one step I'm missing, or two... Please report me back if the solution I provided works for you, and I will look for another solution as well.

Edit: If the solution above didn't work, then I need you to confirm one thing. Try going inside the package contents and open Wineskin.app. If it didn't open, then my theory might be correct... In that case, I'll update the first post later to add a fix.
Reply
#4
(07-10-2019, 02:41 AM)tokaimaster Wrote: '"PCSX2" is damaged and can't be opened.
You should move it to the Trash.'

Hello again,

I was able to reproduce this on macOS Mojave 10.14.5 running on a virtual machine. Here’s a problem why it occurs:
macOS’s Gatekeeper prevents any kind of apps like this one from opening because it wasn’t signed. Therefore, Gatekeeper sees it as a damaged app and encouraged you to move it to the Trash. There is a way to disable Gatekeeper completely, however that will open your computer to serious vulnerabilities. There are two things I can recommend for now:
  • Open your computer to vulnerabilities (such as viruses) by disabling Gatekeeper so you can run PCSX2.app
  • Wait for the fix
Disabling Gatekeeper is like disabling Windows Defender but more complex. If you disable Gatekeeper, that would mean you are telling your computer to let you download apps literally from anywhere, with or without a verified signature. That’s the advantage, but that would mean that your computer can never scan for vulnerabilities again, unless you change your apps download preference back to what it was or re-enable Gatekeeper.

However, the good news is, there is a way to keep Gatekeeper while having the ability to open PCSX2.app to prevent the same error from popping up! Just acknowledge that you will be opening your computer to vulnerabilities for a moment. Follow this:

  1. Open terminal in spotlight or however where you open it.
  2. Enter this command: 
    Code:
    sudo spctl --master-disable

  3. Enter your computer password when promoted. It hides the password for a security reason, not even asterisks.
  4. Open PCSX2.app and click “open” when asked if you’re sure.
  5. It is safe to close PCSX2.app now and…
  6. …enable Gatekeeper again by entering this command in the terminal:
    Code:
    sudo spctl --master-enable

  7. Enter your computer password when promoted (should be done only once, but if it does, do that in the case).
  8. Open PCSX2.app again. It should open just fine now.
Thank you for waiting to let me test this, and now I’ll be able to update the first post so if others like you encountered this same issue in the future. Please let me know if it works for you as well! Smile
Reply
#5
The first post was updated for a new version of wrapper.

I’ve gave it a new name: PCSX2 Running On Mac (or PROM for short!) and it now contain standalone version instead of portable version, so all folders are now found in Documents/PCSX2 folder.

The DMG installer is now smaller (about 1 GB less)!
Reply




Users browsing this thread: 1 Guest(s)