Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[macOS] P.R.O.M. - PCSX2 Running on Mac (64-bit & Now runs on Catalina!)
#1
Hello all!

Of course, today is my first post on this forums as well as my first day of this new account. Regardless, I want to present the new wrapper created for PCSX2 to work properly on Mojave and possibly above. I only tested this on Mojave 10.14.5, so I have no idea if it works below that since the wrapper is ran on 64-bit wine engine instead of 32-bit. I also have no idea if this also will work on Catalina beta, either... and I probably will not test it on Catalina for now. And of course, this port isn't perfect but it works.

And yes, I've tried options here on the forums to get PCSX2 work on macOS, such as PCSX2-CE. Just didn't work as it should for me. And indeed, since Mojave is the last OS to allow 32-bit applications and Catalina no longer allows 32-bit, I've created wrapper to work with Mojave and above, so... HA IN YOUR FACE, APPLE!



P.R.O.M. - PCSX2 Running on Mac
Created by Amarante (firelad97) - Current version: 1.01

This wrapper is intended to work on 64-bit versions of macOS, including Catalina!
Should work on 32-bit versions of macOS as well since the wrapper itself runs on 32-bit version of Wine.

Download PROM v1.01 here!
DMG Installer 3 GB on Mega

Old version is also available here.

Screenshots:

[Image: PS4b12b.jpg]
PCSX2 1.4.0, running .hack//Infection (USA), on Catalina 10.15.2


Make sure to drop your BIOS files inside PCSX2/bios folder found in your Documents folder (not inside package contents!) after launching PROM.

WARNING: DO NOT SELECT OPENGL, SOFTWARE OR HARDWARE, FOR GS RENDER!! This possibly will crash PROM or will not load games at all. This is due to the removal of OpenGL support on recent macOS versions.

Installing PROM
  • Download the DMG installer, linked above.
  • Extract PROM <version>.app anywhere, although one of Applications folders is recommended.
  • Open it. A first-time configuration should run. When it does, new folders in your Documents should be created.
  • Move your BIOS files to ~/<user>/Documents/PCSX2/bios.
  • Proceed with first-time configuration.
  • On plugins page, click 'configure' for SPU2.
  • Confirm that module is set to Portaudio. (should be automatically set for you, otherwise change it)
  • Click 'OK', and then click 'Apply' to save your settings if you changed the module in audio settings.
  • Continue with the configuration as it is.

Updating PCSX2
  • Grab the portable version of PCSX2, and extract files accordingly to:
  • ~/<user>/Documents/PCSX2
  • PROM <version>.app/drive_c/Program Files (x86)/PCSX2 (right-click the app and click 'Open Package Contents')

Changelog

v1.01 - Added DirectX 9, 10, and 11 versions
         - Now runs on Wine32on64 version, now works on Catalina as intended
         - First-time configuration now opens by default when running for the first time

v1.00 - Initial version


Known Issues / FAQs
  • Q: I got the error message saying PROM is damaged or that it should be moved to the Trash.
  • A: This is due to how the security works on Mac computers, known as Gatekeeper. Do as follows below:
  1. Open terminal.
  2. Enter this command to disable Gatekeeper:
    sudo spctl --master-disable
  3. Enter your computer administrator password when prompted. It hides the password for security reasons.
  4. Open the app and click 'Open' when asked if you're sure.
  5. It is safe now to close the app, and then enter the command to re-enable Gatekeeper.
    sudo spctl --master-enable
  6. The app should open normally now.
  • Q: The app won't open at all!
  • A: This might be related to Gatekeeper, but more complex than simply disabling Gatekeeper. For this, you will have to reboot your computer into Recovery OS.
  1. Reboot the computer. Hold COMMAND+R as soon as it starts up, and release when the apple logo and loading bar appear.
  2. In Recovery OS, it will ask you to log in using your computer account. Do that.
  3. Click 'Utilities' menu on the toolbar above, and then click terminal.
  4. Enter the command to disable SIP (System Integrity Protection) and rebooting the computer afterwards:
    csrutil disable; reboot
  5. Once computer finishes rebooting, try opening the app now. It should open just fine.
  6. Optional: However, if you want to re-enable SIP, you can reboot into Recovery OS again and enter the following command:
    csrutil enable; reboot
  7. This will re-enable SIP and then reboot the computer for you.
  • Q: The app froze on the first-time configuration window and won't proceed to next screen!
  • A: Force-quit the app using the "Force Quit..." via apple logo menu. Re-open the app and it should open just fine. This is one-time issue.
  • Q: I've tried the solution above but it kept hanging/freezing.
  • A: Someone found the workaround to this, and you might as well try this. Go to PROM.app/contents/MacOS and open WineskinLauncher. The solution I'm referring to is here.

If there are any issues associated with the wrapper… please let me know as soon as possible and I will do my best to help you out. Smile
Reply

Sponsored links

#2
Hello,

I am new to PCSX2 but I followed the intructions above. I downloaded, copied the app to applications folder, opened package contents, added my PS2 bios file and I got the below message when opening the app.

[Image: view?usp=sharing]

'"PCSX2" is damaged and can't be opened.
You should move it to the Trash.'

I have tried CTRL and Click to open. and Right CLicking and selecting Open but neither worked.

Hoping you can help as I want to re live suikopden 3!

Thanks,

John
Reply
#3
(07-10-2019, 02:41 AM)tokaimaster Wrote: [Image: kUhZYRmCg1GKhLrHJ2ZfHTlV2D_70jI23_3hE36N...3360-h1724]

Try this:
  • Open System Preferences
  • Open Security & Privacy
  • Make sure General tab is toggled
  • Click "Allow..." for PCSX2 that appears below "Allow apps downloaded from:"
Otherwise, I will need to test this on a virtual machine ... because I have no idea why it didn't work for you. There might be one step I'm missing, or two... Please report me back if the solution I provided works for you, and I will look for another solution as well.

Edit: If the solution above didn't work, then I need you to confirm one thing. Try going inside the package contents and open Wineskin.app. If it didn't open, then my theory might be correct... In that case, I'll update the first post later to add a fix.
Reply
#4
(07-10-2019, 02:41 AM)tokaimaster Wrote: '"PCSX2" is damaged and can't be opened.
You should move it to the Trash.'

Hello again,

I was able to reproduce this on macOS Mojave 10.14.5 running on a virtual machine. Here’s a problem why it occurs:
macOS’s Gatekeeper prevents any kind of apps like this one from opening because it wasn’t signed. Therefore, Gatekeeper sees it as a damaged app and encouraged you to move it to the Trash. There is a way to disable Gatekeeper completely, however that will open your computer to serious vulnerabilities. There are two things I can recommend for now:
  • Open your computer to vulnerabilities (such as viruses) by disabling Gatekeeper so you can run PCSX2.app
  • Wait for the fix
Disabling Gatekeeper is like disabling Windows Defender but more complex. If you disable Gatekeeper, that would mean you are telling your computer to let you download apps literally from anywhere, with or without a verified signature. That’s the advantage, but that would mean that your computer can never scan for vulnerabilities again, unless you change your apps download preference back to what it was or re-enable Gatekeeper.

However, the good news is, there is a way to keep Gatekeeper while having the ability to open PCSX2.app to prevent the same error from popping up! Just acknowledge that you will be opening your computer to vulnerabilities for a moment. Follow this:

  1. Open terminal in spotlight or however where you open it.
  2. Enter this command: 
    Code:
    sudo spctl --master-disable

  3. Enter your computer password when promoted. It hides the password for a security reason, not even asterisks.
  4. Open PCSX2.app and click “open” when asked if you’re sure.
  5. It is safe to close PCSX2.app now and…
  6. …enable Gatekeeper again by entering this command in the terminal:
    Code:
    sudo spctl --master-enable

  7. Enter your computer password when promoted (should be done only once, but if it does, do that in the case).
  8. Open PCSX2.app again. It should open just fine now.
Thank you for waiting to let me test this, and now I’ll be able to update the first post so if others like you encountered this same issue in the future. Please let me know if it works for you as well! Smile
Reply
#5
The first post was updated for a new version of wrapper.

I’ve gave it a new name: PCSX2 Running On Mac (or PROM for short!) and it now contain standalone version instead of portable version, so all folders are now found in Documents/PCSX2 folder.

The DMG installer is now smaller (about 1 GB less)!
Reply
#6
Does not work on macos catalina public beta 4.

2019-07-19 21:38:30.586 PROM Testing474623704Wine64-preloader[23526:397744] NSSoftLinking - The function 'SLSIsSuppressedByScreenTime' can't be found in the (null) framework.
2019-07-19 21:38:30.698 PROM Testing474623704Wine64-preloader[23503:397624] NSSoftLinking - The function 'SLSIsSuppressedByScreenTime' can't be found in the (null) framework.
/Applications/PROM.app/Contents/Frameworks/wswine.bundle/lib64/../bin/wine-preloader: line 2: /Applications/PROM.app/Contents/Frameworks/wswine.bundle/lib64/../bin/PROM Testing474623704Wine-preloader: Bad CPU type in executable
wine: Unhandled page fault on read access to 0x00000050 at address 0x7fff3c4d476d (thread 001c), starting debugger...
001c:err:seh:start_debugger Couldn't start debugger ("false") (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger
001c:err:seh:setup_exception stack overflow 1712 bytes in thread 001c eip 000000007bc31b17 esp 0000000000790f60 stack 0x790000-0x791000-0x990000
/Applications/PROM.app/Contents/Frameworks/wswine.bundle/lib64/../bin/wine64-preloader: line 2: 23521 Killed: 9 FREETYPE_PROPERTIES="truetype:interpreter-version=35" DYLD_FALLBACK_LIBRARY_PATH="${WINESKIN_LIB_PATH_FOR_FALLBACK}" "$(dirname "$0")/PROM Testing474623704Wine64-preloader" "$@"
Reply
#7
(07-20-2019, 03:39 AM)mentaluproar Wrote: Does not work on macos catalina public beta 4.

Hello, can you please tell me what your specs are on your Mac? The log said it seems to be trying to call something from your CPU, but failed. Please let me know so I can dig into this issue.
I also will be testing this on Catalina soon, so stay tuned. Smile
Reply
#8
Wow! Thank you sir for your effort!
I'm testing it on a Macbook Pro Late '16 Mojave 10.14.6 and will report back soon.

I tried Tekken 4 and Tekken 5 and performance is very slow with mesh/geometry artifacts. This is with default settings.
Reply
#9
(08-02-2019, 12:45 PM)jubei Wrote: I tried Tekken 4 and Tekken 5 and performance is very slow with mesh/geometry artifacts. This is with default settings.

That is to be expected with a late '16 MacBook. What is its specs? Your graphics card might be an issue. If you only have an integrated graphics card, Intel, then PCSX2 will not run well with it.
Reply
#10
(08-02-2019, 04:56 PM)firelad97 Wrote: That is to be expected with a late '16 MacBook. What is its specs? Your graphics card might be an issue. If you only have an integrated graphics card, Intel, then PCSX2 will not run well with it.
Thanks for your reply!

2,9 GHz Intel Core i7
16 GB 2133 MHz LPDDR3
Radeon Pro 460 4 GB + Intel HD Graphics 530 1536 MB

Perhaps higher specs will result in better performance.
Reply




Users browsing this thread: 1 Guest(s)