Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[macOS] P.R.O.M. - PCSX2 Running on Mac (64-bit & Now runs on Catalina!)
#21
(01-22-2020, 05:28 PM)MartiMan Wrote: Hi, I'm running 10.15.2 and the first time configuration keeps hanging after pressing next (multiple tries after forced quit)...
Any ideas?

What are you using to force-quit it? Should not be Activity Monitor or from context menu, but via Apple menu. Shown like so:
[Image: FOQjTjF.png]

EDIT: For some reason the screenshot showed the item name differently. Should says "Force Quit...".

EDIT2: Forgot to mention that if issues persist, it's also might be worth it to check Activity Monitor for any running PROM processes. Kill them all, and if they are still running in foreground, force-quit them via "Force Quit...". It *should* work fine afterwards. If not, please let me ASAP.
Reply

Sponsored links

#22
(01-23-2020, 12:03 AM)firelad97 Wrote: What are you using to force-quit it? Should not be Activity Monitor or from context menu, but via Apple menu. Shown like so:
[Image: FOQjTjF.png]

EDIT: For some reason the screenshot showed the item name differently. Should says "Force Quit...".

EDIT2: Forgot to mention that if issues persist, it's also might be worth it to check Activity Monitor for any running PROM processes. Kill them all, and if they are still running in foreground, force-quit them via "Force Quit...". It *should* work fine afterwards. If not, please let me ASAP.

Thanks for your quick reply.
I fully restarted the computer and did following steps:

This is Activity Monitor before running PROM

            


This is after opening

            


This is after pressing next for the first time

            


This is after pressing next for the second time

            

The disk usage (written) doesn't get more than 2.3MB, even after 5 min.

Also no useful entries in console.

Thanks
Reply
#23
(01-23-2020, 03:07 PM)MartiMan Wrote: Thanks for your quick reply.
I fully restarted the computer and did following steps:

This is Activity Monitor before running PROM

        


This is after opening

        


This is after pressing next for the first time

        


This is after pressing next for the second time

        

The disk usage (written) doesn't get more than 2.3MB, even after 5 min.

Also no useful entries in console.

Thanks
Hey! I has this problem like you.
right click PROM>contents>MacOS> and open WineSkinLauncher. After this will open WORKING installer!)
Reply
#24
(01-24-2020, 02:57 AM)Dorian.D Wrote: Hey! I has this problem like you.
right click PROM>contents>MacOS> and open WineSkinLauncher. After this will open WORKING installer!)

Thank you for helping solve the problem I wasn't able to. I'll add this to the Known Issues / FAQs.

@MartiMan, did this solution helped you?
Reply
#25
(01-24-2020, 07:03 AM)firelad97 Wrote: Thank you for helping solve the problem I wasn't able to. I'll add this to the Known Issues / FAQs.

@MartiMan, did this solution helped you?
Yes!!! Thanks ? 
For some reason I had to do it twice?!

Second time I got this:

Martijns-MBP:~ martijnsmeets$ /Applications/PROM\ v1.01.app/Contents/MacOS/WineskinLauncher ; exit;
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.
Deleting expired sessions...37 completed.

[Process completed]

And the setup started...
Reply
#26
(01-24-2020, 07:03 AM)firelad97 Wrote: Thank you for helping solve the problem I wasn't able to. I'll add this to the Known Issues / FAQs.

@MartiMan, did this solution helped you?
Maybe You can help me? My config:
   
But in emulation FPS only 9-10.
I tried all plugins, all renders and all settings on adapters...

when emu is running %GPU keeping at 30-40%
Maybe I'm doing something wrong?

will PROM support OpenGL render in future versions?
Reply
#27
(01-24-2020, 12:55 PM)MartiMan Wrote: Yes!!! Thanks ? 
For some reason I had to do it twice?!

Second time I got this:

Martijns-MBP:~ martijnsmeets$ /Applications/PROM\ v1.01.app/Contents/MacOS/WineskinLauncher ; exit;
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.
Deleting expired sessions...37 completed.

[Process completed]

And the setup started...

You're the most welcome. Should also thank Dorian.D. Smile And not sure why it didn't work first time, but at least it worked a second time. Wink

(01-24-2020, 02:13 PM)Dorian.D Wrote: Maybe You can help me? My config:

But in emulation FPS only 9-10.
I tried all plugins, all renders and all settings on adapters...

when emu is running %GPU keeping at 30-40%
Maybe I'm doing something wrong?

will PROM support OpenGL render in future versions?

Sadly PROM is only the wrapper that allows PCSX2 to run on Mac. And macOS Mojave 10.14 and above no longer supports OpenGL, in favor of Metal. In some future if WINE adds the support for Metal to "emulate" OpenGL, then *maybe*. However, I can't do anything about it.

If your emulation runs slow, it's a chance that WINE mistakes Intel as your current GPU and uses it. Does the graphic plugin says Radeon is selected? If it is, then I'm not sure what's causing it. I will keep testing and see what causes this. Thank you for reporting though!
Reply
#28
(01-24-2020, 07:55 PM)firelad97 Wrote: You're the most welcome. Should also thank Dorian.D. Smile And not sure why it didn't work first time, but at least it worked a second time. Wink


Sadly PROM is only the wrapper that allows PCSX2 to run on Mac. And macOS Mojave 10.14 and above no longer supports OpenGL, in favor of Metal. In some future if WINE adds the support for Metal to "emulate" OpenGL, then *maybe*. However, I can't do anything about it.

If your emulation runs slow, it's a chance that WINE mistakes Intel as your current GPU and uses it. Does the graphic plugin says Radeon is selected? If it is, then I'm not sure what's causing it. I will keep testing and see what causes this. Thank you for reporting though!


Hi! I recently came trying to play PS2 on my Mac... You're very active here, thank you very much for your efforts. It's a very nostalgic console for me, really, thanks for everything!

I can't run on Catalina. I got the damaged file error...

Maybe is it because of this:?

https://www.theverge.com/2019/6/4/18651872/apple-macos-catalina-zsh-bash-shell-replacement-features

If you could run on Catalina, maybe you upgraded your Mac from a previous version, for those who came directly on Catalina they may find this problem. Unfortunately, I voluntarily changed from bash to zsh.

Or maybe that doesn't mean anything at all. Sad  Sad
Reply
#29
Hello! Thank you so much for posting this!

I am having an issue though, every time I try to open the first time configuration and click the next button, the application stops responding. 

I am currently running on Mojave

[Image: TMwPZ8d]






Attached Files Thumbnail(s)
   
Reply
#30
Hi, I'm new here and I followed your tutorial to download the app. I downloaded the .dmg file but I can't extract it. It verified the file like usual but nothing happened after that. I'm on Catalina.

   
Reply




Users browsing this thread: 2 Guest(s)